• hdu Just a Hook


    Just a Hook

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 9939    Accepted Submission(s): 4882

    Problem Description
    In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.
     
    Now Pudge wants to do some operations on the hook.
    Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:
    For each cupreous stick, the value is 1. For each silver stick, the value is 2. For each golden stick, the value is 3.
    Pudge wants to know the total value of the hook after performing the operations. You may consider the original hook is made up of cupreous sticks.
     
    Input
    The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
     
    Output
    For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
     
    Sample Input
    1 10 2 1 5 2 5 9 3
     
    Sample Output
    Case 1: The total value of the hook is 24.
     
    Source
     
    Recommend
    wangye
     
    分析:线段树:成段替换,成段求和。
    #include<cstdio>
    #include<cstring>
    #define lson l,m,rt<<1
    #define rson m+1,r,rt<<1|1
    int sum[1 << 18];
    int col[1 << 18];
    
    void pushup(int rt) {
        sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];
    }
    
    void pushdown(int rt, int len) {
        if (col[rt]) {
            col[rt << 1] = col[rt << 1 | 1] = col[rt];
            col[rt] = 0;
            sum[rt << 1] = (len - (len >> 1)) * col[rt << 1];
            sum[rt << 1 | 1] = (len >> 1) * col[rt << 1 | 1];
        }
    }
    
    void build(int l, int r, int rt) {
        if (l == r) {
            sum[rt] = 1;
            return;
        }
        int m=(l+r)>>1;
        build(lson);
        build(rson);
        pushup(rt);
    }
    
    void update(int L, int R, int c, int l, int r, int rt) {
        if (L <= l && R >= r) {
            col[rt] = c;
            sum[rt] = c * (r - l + 1);
            return;
        }
        pushdown(rt, r - l + 1);
        int m = (l + r) >> 1;
        if (L <= m)
            update(L, R, c, lson);
        if (R > m)
            update(L, R, c, rson);
        pushup(rt);
    }
    
    int main() {
        int n, t, T, i, q, a, b, c;
        scanf("%d", &T);
        for (t = 1; t <= T; ++t) {
            scanf("%d%d", &n, &q);
            build(1, n, 1);
            memset(col, 0, sizeof (col));
            while (q--) {
                scanf("%d%d%d", &a, &b, &c);
                update(a, b, c, 1, n, 1);
            }
            printf("Case %d: The total value of the hook is %d.\n", t, sum[1]);
        }
        return 0;
    }
     
  • 相关阅读:
    房价
    Jsrender初体验
    GCD XOR UVA
    GCD
    Aladdin and the Flying Carpet LightOJ
    HDU6035 2017多校第一场1003 树形DP
    F
    C
    B
    An Easy Physics Problem HDU
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2717019.html
Copyright © 2020-2023  润新知