• hdu A Bug's Life


    A Bug's Life

    Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 353    Accepted Submission(s): 133
     
    Problem Description
    Background Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
    Problem Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
     
    Input
    The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
     
    Output
                The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.
     
    Sample Input
    2
    3 3
    1 2
    2 3
    1 3
    4 2
    1 2
    3 4
     
    Sample Output
    Scenario #1:
    Suspicious bugs found!
    
    Scenario #2:
    No suspicious bugs found!
    Hint
    Huge input,scanf is recommended.
     
     
    Source
    TUD Programming Contest 2005, Darmstadt, Germany
     
    Recommend
    linle

    分析:路径压缩的并查集。用给点相对于根节点的距离%2表示是同性还是异性。merge()中修改被吞并树根的值使之满足所给两点的差距为奇数,find()中利用路径压缩将该树相对于已改变的根节点的奇偶值修改正确。

    #include<cstdio>
    #include<cstring>
    int fa[2010],rank[2010];
    int n,flag;
    int find(int x)
    {
        if(fa[x]==x)
            return x;
        int t;
        t=find(fa[x]);
        rank[x]=(rank[x]+rank[fa[x]])%2;
        fa[x]=t;
        return t;
    }
    void merge(int x,int y)
    {
        int fx,fy;
        fx=find(x);
        fy=find(y);
      //  printf("x=%d y=%d fx=%d fy=%d\n",x,y,fx,fy);
        if(fx==fy)
        {
            if(rank[x]==rank[y])
            {
                flag=0;
            }
        }
        else
        {
            fa[fx]=fy;
            rank[fx]=(rank[x]+rank[y]+1)%2;
        }
    }
    int main()
    {
        int T,m,i,a,b,t;
        scanf("%d",&T);
        for(t=1;t<=T;++t)
        {
            scanf("%d%d",&n,&m);
            flag=1;
            memset(rank,0,sizeof(rank));
            for(i=1;i<=n;++i)
            {
                fa[i]=i;
            }
            while(m--)
            {
                scanf("%d%d",&a,&b);
                if(!flag)
                    continue;
                merge(a,b);
            }
            printf("Scenario #%d:\n",t);
            if(flag)
                printf("No suspicious bugs found!\n\n");
            else
                printf("Suspicious bugs found!\n\n");
        }
        return 0;
    }
  • 相关阅读:
    Qt uchar * 转 QImage
    WIN10 蓝牙连接音箱之后,音量调节无效,音量从1-100,声音一样大,都是最大声,可以静音(解决方案)
    OpenGL 保存bmp图像
    Qt 使用自带的OpenGL模块开发程序
    OpenCVSharp介绍
    OpenCV介绍
    OpenAL介绍
    OpenCL介绍
    OpenGL介绍
    Qt 无法打开包括文件:“QGLWidget”: No such file or directory
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2672396.html
Copyright © 2020-2023  润新知