• hdu find the most comfortable road


    find the most comfortable road

    Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 88    Accepted Submission(s): 45
     
    Problem Description
    XX星有许多城市,城市之间通过一种奇怪的高速公路SARS(Super Air Roam Structure---超级空中漫游结构)进行交流,每条SARS都对行驶在上面的Flycar限制了固定的Speed,同时XX星人对 Flycar的“舒适度”有特殊要求,即乘坐过程中最高速度与最低速度的差越小乘坐越舒服 ,(理解为SARS的限速要求,flycar必须瞬间提速/降速,痛苦呀 ), 但XX星人对时间却没那么多要求。要你找出一条城市间的最舒适的路径。(SARS是双向的)。
     
    Input
    输入包括多个测试实例,每个实例包括: 第一行有2个正整数n (1<n<=200)和m (m<=1000),表示有N个城市和M条SARS。 接下来的行是三个正整数StartCity,EndCity,speed,表示从表面上看StartCity到EndCity,限速为speedSARS。speed<=1000000 然后是一个正整数Q(Q<11),表示寻路的个数。 接下来Q行每行有2个正整数Start,End, 表示寻路的起终点。
     
    Output
    每个寻路要求打印一行,仅输出一个非负整数表示最佳路线的舒适度最高速与最低速的差。如果起点和终点不能到达,那么输出-1。
     
    Sample Input
    4 4
    1 2 2
    2 3 4
    1 4 1
    3 4 2
    2
    1 3
    1 2
     
    Sample Output
    1
    0
     
    Author
    ailyanlu
     
    Source
    HDU 2007-Spring Programming Contest - Warm Up (1)
     
    Recommend
    8600

    分析:将路按速度sort一次后,枚举最小权边,对于每个最小,都可以用一次Kruskal算法来解到最长边(并查集合并直至所求两点根节点相同)。枚举完后选择差值最小的即为所求。

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    using namespace std;
    int n, m;
    int fa[210];
    
    typedef struct S {
        int u, v, w;
    } EAGE;
    EAGE e[1010];
    
    int find(int x) {
        if (x == fa[x])
            return x;
        fa[x] = find(fa[x]);
        return fa[x];
    }
    
    void merge(int x, int y) {
        int fx, fy;
        fx = find(x);
        fy = find(y);
        if (fx != fy) {
            fa[fx] = fy;
        }
    }
    
    bool cmp(EAGE a, EAGE b) {
        return a.w < b.w;
    }
    
    int main() {
        int i, q, a, b, ok, j;
        int min;
        while (scanf("%d", &n) != EOF) {    
            scanf("%d", &m);
            for (i = 0; i < m; ++i)
                scanf("%d%d%d", &e[i].u, &e[i].v, &e[i].w);
            scanf("%d", &q);
            sort(e, e + m, cmp);
            while (q--) {
                min = 10000000;
                scanf("%d%d", &a, &b);
                for (i = 0; i < m; ++i) {
                    ok = 0;
                    for (j = 1; j <= n; ++j)
                        fa[j] = j;
                    for (j = i; j < m; ++j) {
                        merge(e[j].u, e[j].v);
                        if (find(a) == find(b)) {
                            ok = 1;
                            break;
                        }
                    }
                    if (ok) {
                        ok = e[j].w - e[i].w;
                        if (ok < min)
                            min = ok;
                    }
                    if(min>=1000000)
                    {
                        min=-1;
                        break;
                    }
                }
                printf("%d\n", min);
            }
        }
        return 0;
    
    }
  • 相关阅读:
    排序:归并排序
    错误编码 = 10022 错误消息 = SDK 组件 Qupaisdk 启动出错,错误消息为 [Qupaisdk], the android stack error message is Fail to start the plugin, which is caused by No implem
    关于百川趣拍64位的问题
    在 APK 中找不到对应的 securityguard***.so 文件或者 so 文件载入出错
    趣拍proguard配置
    android多国语言文件夹
    错误编码 = 17
    阿里百川趣拍接入指南
    Conversion to Dalvik format failed:Unable toexecute dex: method ID not in [0, 0xffff]: 65536
    Conversion to Dalvik format failed:Unable toexecute dex: method ID not in [0, 0xffff]: 65536
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2672379.html
Copyright © 2020-2023  润新知