• hdu Nightmare


    Nightmare

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 75    Accepted Submission(s): 39
     
    Problem Description
    Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.
    Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.
    Here are some rules: 1. We can assume the labyrinth is a 2 array. 2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too. 3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth. 4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb. 5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish. 6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
     
    Input
    The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. There are five integers which indicate the different type of area in the labyrinth: 0: The area is a wall, Ignatius should not walk on it. 1: The area contains nothing, Ignatius can walk on it. 2: Ignatius' start position, Ignatius starts his escape from this position. 3: The exit of the labyrinth, Ignatius' target position. 4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
     
    Output
    For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
     
    Sample Input
    3
    3 3
    2 1 1
    1 1 0
    1 1 3
    4 8
    2 1 1 0 1 1 1 0
    1 0 4 1 1 0 4 1
    1 0 0 0 0 0 0 1
    1 1 1 4 1 1 1 3
    5 8
    1 2 1 1 1 1 1 4 
    1 0 0 0 1 0 0 1 
    1 4 1 0 1 1 0 1 
    1 0 0 0 0 3 0 1 
    1 1 4 1 1 1 1 1 
     
    Sample Output
    4
    -1
    13
     
    Author
    Ignatius.L
     

    分析:可以走回头路的bfs,时间复原工具的地方不能走回头路。

    #include<iostream>
    #include<queue>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    
    typedef struct S {
        int x, y;
        int time;
        int step;
    } STEP;
    STEP now, next;
    int map[10][10];
    int dx[] = {1, -1, 0, 0};
    int dy[] = {0, 0, 1, -1};
    int vis[10][10];
    
    int main() {
        int a, b, c, d, m, n, i, j, xx, yy;
        int T;
        scanf("%d", &T);
        while (T--) {
            scanf("%d%d", &m, &n);
            for (i = 0; i < m; ++i) {
                for (j = 0; j < n; ++j) {
                    scanf("%d", &map[i][j]);
                    if (map[i][j] == 2) {
                        a = i;
                        b = j;
                    } else if (map[i][j] == 3) {
                        c = i;
                        d = j;
                    }
                }
            }
            queue <STEP> q;
            now.x = a;
            now.y = b;
            now.time = 6;
            now.step = 0;
    
    
            q.push(now);
            while (!q.empty()) {
                now = q.front();
                q.pop();
                //    printf("x=%d y=%d time=%d\n",now.x,now.y,now.time);
                next.time = now.time - 1;
                next.step = now.step + 1;
                if (now.time == 2) {
                    for (i = 0; i < 4; ++i) {
                        xx = now.x + dx[i];
                        yy = now.y + dy[i];
                        if (xx == c && yy == d) {
                            printf("%d\n", next.step);
                            goto L;
                        }
                        if (map[xx][yy] == 4) {
                            next.time = 6;
                            map[xx][yy] = 0;
                            next.x = xx;
                            next.y = yy;
                            q.push(next);
                        }
                    }
    
                } else {
                    for (i = 0; i < 4; ++i) {
                        xx = now.x + dx[i];
                        yy = now.y + dy[i];
                        if (xx == c && yy == d) {
                            printf("%d\n", next.step);
                            goto L;
                        }
                        if (xx >= 0 && xx < m && yy >= 0 && yy < n && map[xx][yy]) {
                            //    printf("xx=%d yy=%d\n",xx,yy);
    
                            if (map[xx][yy] == 4) {
                                next.time = 6;
                                map[xx][yy] = 0;
                            }
                            next.x = xx;
                            next.y = yy;
                            q.push(next);
                        }
                    }
                }
    
            }
            printf("-1\n");
    L:
            ;
    
        }
        return 0;
    }
  • 相关阅读:
    回文字符串问题
    Linux添加nfs共享存储盘
    解读nginx配置
    制作自己的nginx rpm包
    linux编译安装时常见错误解决办法
    redis单机及集群安装
    nginx ssl
    vsftp配置详解
    Linux-文件系统的简单操作
    Linux-Vim编辑器
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2666240.html
Copyright © 2020-2023  润新知