• hdu Strange fuction


    Strange fuction

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 269    Accepted Submission(s): 233
     
    Problem Description
    Now, here is a fuction:   F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100) Can you find the minimum value when x is between 0 and 100.
     
    Input
    The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
     
    Output
                Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
     
    Sample Input
    2
    100
    200
     
    Sample Output
    -74.4291
    -178.8534
     
    Author
    Redow
     
     
    Recommend
    lcy

    分析:方法一、对导数二分求的导数为0点;方法二、直接对函数三分求最值。

    二分代码:

    #include<cstdio>
    #include<cmath>
    #define eps 1e-15
    double f(double x,double y)
    {
        return 6 * pow(x,7)+8*pow(x,6)+7*x*x*x+5*x*x-y*x;
    }
    double g(double x)
    {
        return 42*pow(x,6)+48*pow(x,5)+21*x*x+10*x;
    }
    int main()
    {
        int T;
        double y,a,b,m;
        scanf("%d",&T);
        while(T--)
        {
            scanf("%lf",&y);
            if(g(0.0)>=y)
                printf("%.4f\n",f(0.0,y));
            else if(g(100.0)<=y)
                printf("%.4f\n",f(100.0,y));
            else
            {
                a=0.0;
                b=100.0;
                while(b-a>eps)
                {
                    m=(a+b)/2;
                    if(g(m)>y)
                        b=m;
                    else
                        a=m;
                }
                printf("%.4f\n",f(m,y));
            }
        }
        return 0;
    }

    三分代码:

    #include<cstdio>
    #include<cmath>
    #define eps 1e-15
    double y;
    
    double f(double x) {
        return 6 * pow(x, 7) + 8 * pow(x, 6) + 7 * x * x * x + 5 * x * x - y*x;
    }
    
    int main() {
        int T;
        double a, b, c, d;
        scanf("%d", &T);
        while (T--) {
            scanf("%lf", &y);
            a = 0.0;
            b = 100.0;
            while (b - a > eps) {
                c = (a + b) / 2;
                d = (b + c) / 2;
                if (f(c) < f(d))
                    b = d;
                else
                    a = c;
            }
            printf("%.4f\n", f(a));
        }
        return 0;
    }

  • 相关阅读:
    Linux利器strace
    记一次MongoDB性能问题
    mongodb慢查询记录
    PHP操作MongoDB学习笔记
    字典NSDictionary的常见用法
    字典与自定义对象的相互转换
    URLString中文字符转义
    常见序列化与反序列化方法
    Swift处理异常的三种方式-try
    客户端Socket使用步骤
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2666066.html
Copyright © 2020-2023  润新知