• hdu Queuing


    Queuing

    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 608    Accepted Submission(s): 278
     
    Problem Description
    Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time.
    Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue. Your task is to calculate the number of E-queues mod M with length L by writing a program.
     
    Input
    Input a length L (0 <= L <= 10 6) and M.
     
    Output
                Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
     
    Sample Input
    3 8
    4 7
    4 8
     
    Sample Output
    6
    2
    1
     
    Author
    WhereIsHeroFrom
     
    Source
    HDU 1st “Vegetable-Birds Cup” Programming Open Contest
     
    Recommend
    lcy
     

    分析:开始研究4种状态fm,ff,mm,mf,TLE。接着研究6种状态 ffm,fmm,mfm,mmm,mff,mmf,继续超时。只好从队末加入往前分析,若新来的s[n]=m,那么n前面只要合法这个就合法,即f[n]+=f[n-1]。若新来一个f,那么必须s[n-2]=m。此时,若f[n-1]=m,那么n-2前面合法这个就合法,即f[n]+=f[n-3];若f[n-1]=f,那么必须f[n-3]=m,那么只要n-3前面合法这个就合法,即f[n]+=f[n-4]。

    #include <stdio.h>
    #define N 1000001
    #define M 30
    
    char node[N][M];
    
    void init()
    {
        int i,j;
        for(i=1;i<=M;i++)
        {
            node[1][i]=2%i;
            node[2][i]=4%i;
            node[3][i]=6%i;
            node[4][i]=9%i;
            for (j=5;j<=N;j++)
            {
                node[j][i]=(node[j-1][i]+node[j-3][i]+node[j-4][i])%i;
            }
        }
    }
    
    int main()
    {
        init();
        int n,m;
        while (~scanf("%d%d",&n,&m))
        {
            printf("%d\n",node[n][m]);
        }
        return 0;
    }
  • 相关阅读:
    Mysql
    JavaScript常用事件
    css
    HTML
    判断pc还是手机打开跳转到别的网页
    queue 队列
    兼容firstChild和firstElementChild
    总结各种width,height,top,left
    原生js提取非行间样式
    ie8 不支持media
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2664733.html
Copyright © 2020-2023  润新知