• hdu Tian Ji The Horse Racing


    Tian Ji -- The Horse Racing

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 2280    Accepted Submission(s): 601
     
    Problem Description
    Here is a famous story in Chinese history.
    "That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."
    "Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."
    "Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."
    "Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."
    "It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"

    Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...
    However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.
    In this problem, you are asked to write a program to solve this special case of matching problem.
     
    Input
    The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.
     
    Output
    For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.
     
    Sample Input
    3
    92 83 71
    95 87 74
    2
    20 20
    20 20
    2
    20 19
    22 18
    0
     
    Sample Output
    200
    0
    0
     
     
    Source
    2004 Asia Regional Shanghai
     
    Recommend
    JGShining

    分析:1.田忌最快大于王最快,赢1;2.田忌最快小于王最快,让田忌最慢消耗掉王最快,输1;3.田忌最快等于王最快,需深入分析:对于第3种情况,关键在于怎样消耗掉王最快的马,但又保证田忌最慢的马不会吃亏,自然想到要把所有田忌最慢的能获胜的马先让他们获胜,再用剩下的田忌马最慢的消耗王最快的。所以此时,我们让田忌最慢的马与王最慢的比较,若大于,则赢1。直到不能赢了,则让其去消耗王最快的。

    #include<cstdio>
    #include<algorithm>
    #include<iostream>
    #include<cstring>
    using namespace std;
    int tj[1010], king[1010];
    int a, b, c, d, n;
    int sum;
    
    bool cmp(int x, int y) {
        return x>y;
    }
    
    int main() {
        int i;
        while (scanf("%d", &n) != EOF && n) {
            for (i = 0; i < n; ++i)
                scanf("%d", &tj[i]);
            for (i = 0; i < n; ++i)
                scanf("%d", &king[i]);
            a = b = 0;
            c = d = n - 1;
            sum = 0;
            sort(tj, tj + n, cmp);
            sort(king, king + n, cmp);
            for (i = 0; i < n; ++i) {
                if (tj[a] > king[b]) {
                    sum++;
                    ++a;
                    ++b;
                } else if (tj[a] < king[b]) {
                    --sum;
                    --c;
                    ++b;
                } else {
                    while (tj[c] > king[d]) {
                        --c;
                        --d;
                        ++i;
                        ++sum;
                        if (i >= n)
                            goto L;
                    }
                    if (tj[c] < king[b]) {
                        --sum;
                        --c;
                        ++b;
                    }
                }
            }
    L:
            printf("%d\n", 200 * sum);
        }
        return 0;
    }
  • 相关阅读:
    LR学习笔记八 之 初识LR动态链接库
    LR学习笔记七 之 LR录制sql脚本
    LR学习笔记三 之 界面分析
    LoadRunner学习笔记一
    LR学习笔记四 之 调试、日志、动态运行
    协调世界时间 UTC
    InnerText和InnerXml的区别
    避免 showModalDialog 弹出新窗体
    嵌套SELECT语句
    XmlElement和XmlNode的区别
  • 原文地址:https://www.cnblogs.com/baidongtan/p/2662809.html
Copyright © 2020-2023  润新知