Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3134 Accepted: 1911
Description
The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.
Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.
Input
One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).
Output
One line for each case, either with a number stating the minimal cost or containing the word Impossible.
Sample Input
3
1033 8179
1373 8017
1033 1033
Sample Output
6
7
0
Source
Northwestern Europe 2006
//
#include <iostream>
#include <queue>
using namespace std;
int main(int argc, char* argv[])
{
//init prime table
bool prime[10001];
memset(prime,1,sizeof (prime));
prime[0] = false;prime[1] = false;
for (int i = 2; i < 5000; ++i)
{
int k = 2;
int next;
while((next = (k++) * i) < 10000)
prime[next] = false;
}
int cases;
cin >> cases;
int beg, end;
int step;
int visited[10001];
int base[4]= {1, 10, 100, 1000};
for (int c = 0; c < cases; ++c)
{
scanf("%d %d", &beg, &end);
memset(visited, -1, sizeof(visited));
queue<int> q;
q.push(beg);
visited[beg] = 0;
step = -1;
while (!q.empty())
{
int cur = q.front();
q.pop();
if (cur == end)
{
step = visited[cur];
break;
}
for (int i = 0; i < 4; ++i)
{
for (int j = 0; j < 10; ++j)
{
int l = cur / (base[i] * 10);
int r = cur % base[i];
int num = l * base[i] * 10 + j * base[i] + r;
if (num > 1000 && num != cur && prime[num] == true && visited[num] == -1)
{
q.push(num);
visited[num] = visited[cur] + 1;
}
}
}
}
if (step == -1)cout << "Impossible\n";
else cout << step << endl;
}
return 0;
}