• HDU2844 Coins 多重背包


    Coins

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 12330    Accepted Submission(s): 4922


    Problem Description

    Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

     

     

    Input

    The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

     

     

    Output

    For each test case output the answer on a single line.

     

     

    Sample Input

    3 10

    1 2 4 2 1 1

    2 5

    1 4 2 1

    0 0

     

     

    Sample Output

    8

    4

     

     

    题意:Tony想要买一个东西,他只有n中硬币每种硬币的面值为a[i]每种硬币的数量为c[i]要买的物品价值不超过m

    输入:第一行输入n和m,第二行输入n个硬币的面值和n个硬币的数量,输入0 0结束

    输出:1到m之间有多少价格Tony可以支付

     

    #include <iostream>
    #include <cstring>
    #define INF 0x3f3f3f3f
    using namespace std;
    int f[111111],a[111],c[111];
    int n,m;
    
    //m背包的总容量、v物品的体积、w物品的价值
    void OneZeroPack(int m,int v,int w)  //0-1背包
    {
        for(int i=m;i>=v;i--)
            f[i]=max(f[i],f[i-v]+w);
    }
    
    //m背包的总容量、v物品的体积、w物品的价值
    void CompletePack(int m,int v,int w)  //完全背包
    {
        for(int i=v;i<=m;i++)
            f[i]=max(f[i],f[i-v]+w);
    }
    
    //m背包的总容量、v物品的体积、w物品的价值、num物品的数量
    void MultiplePack(int m,int v,int w,int num)//多重背包
    {
        if(v*num>=m)
        {
            CompletePack(m,v,w);
            return ;
        }
        int k=1;
        for(k=1;k<=num;k<<=1)
        {
            OneZeroPack(m,k*v,k*w);
            num=num-k;
        }
        if(num)
            OneZeroPack(m,num*v,num*w);
    }
    
    int main()
    {
        while(cin>>n>>m)
        {
            if(n==0&&m==0)  break;
            for(int i=0;i<n;i++)
                cin>>a[i];
            for(int i=0;i<n;i++)
                cin>>c[i];
            for(int i=0;i<=m;i++)   f[i]=-INF;
            f[0]=0;
            for(int i=0;i<n;i++)
            {
                MultiplePack(m,a[i],a[i],c[i]);
            }
            int sum=0;
            for(int i=1;i<=m;i++)
                    if(f[i]>0)    sum++;
            cout<<sum<<endl;
        }
        return 0;
    }
    View Code
  • 相关阅读:
    navicat for mysql 10.1.7注册码
    去除GHOST版系统自带的2345流氓软件
    利用EXCEL表实现网页数据采集到MYSQL数据库
    Java开发的一个简单截屏工具
    初学JSP+Servlet常见的错误
    从零单排Linux – 3 – 目录结构
    从零单排Linux – 2 – 目录权限
    从零单排Linux – 1 – 简单命令
    在虚拟机中安装Linux
    随机生成MyEclipse注册码
  • 原文地址:https://www.cnblogs.com/asuml/p/5730400.html
Copyright © 2020-2023  润新知