• WA七次,疯了》》》》》OTZ


    Counting Game
    There are n people standing in a line, playing a famous game called ``counting". When the game begins, the leftmost person says ``1" loudly, then the second person (people are numbered 1 to n from left to right) says ``2" loudly. This is followed by the 3rd person saying ``3" and the 4th person say ``4", and so on. When the n-th person (i.e. the rightmost person) said ``n" loudly, the next turn goes to his immediate left person (i.e. the (n - 1)-th person), who should say ``n + 1" loudly, then the (n - 2)-th person should say ``n + 2" loudly. After the leftmost person spoke again, the counting goes right again.
    There is a catch, though (otherwise, the game would be very boring!): if a person should say a number who is a multiple of 7, or its decimal representation contains the digit 7, he should clap instead! The following tables shows us the counting process for n = 4 (`X' represents a clap). When the 3rd person claps for the 4th time, he's actually counting 35.
    Person 1 2 3 4 3 2 1 2 3
    Action 1 2 3 4 5 6 X 8 9
    Person 4 3 2 1 2 3 4 3 2
    Action 10 11 12 13 X 15 16 X 18
    Person 1 2 3 4 3 2 1 2 3
    Action 19 20 X 22 23 24 25 26 X
    Person 4 3 2 1 2 3 4 3 2
    Action X 29 30 31 32 33 34 X 36
    Given n, m and k, your task is to find out, when the m-th person claps for the k-th time, what is the actual number being counted.
    Input
    There will be at most 10 test cases in the input. Each test case contains three integers n, m and k ( 2$ \le$n$ \le$100, 1$ \le$m$ \le$n, 1$ \le$k$ \le$100) in a single line. The last test case is followed by a line with n = m = k = 0, which should not be processed.
    Output
    For each line, print the actual number being counted, when the m-th person claps for the k-th time. If this can never happen, print ` -1'.
    Sample Input
    4 3 1
    4 3 2
    4 3 3
    4 3 4
    0 0 0
    Sample Output
    17
    21
    27
    35

    就是不知道-1的情况,感觉一直报数下去肯定就能喊到啊。

    程序如下,还是没过

    #include<stdio.h>
    main()
    {int i;
    int a,n,m,k,t;
    while(scanf("%d %d %d",&n,&m,&k)!=EOF)
    {i=0;
    int x[108]={0};
    if(n==0&m==0&k==0)
    break;
    while(1)
    {
    i++;
    if(i%7==0||i%10==7||i/10%10==7||i/100%10==7)
    {
    if(i<n)
    x[i]++;
    else
    {t=(i-n)%(2*n-2);
    if(t<n)
    x[n-t]++;
    else
    {
    t=t-n+1;
    x[t+1]++;
    }

    }
    }if(x[m]==k)
    break;
    if(i>1000000)
    break;
    }if(i>1000000)
    printf("-1\n");
    else
    printf("%d\n",i);
    }
    }

  • 相关阅读:
    TCP/IP模型及OSI七层参考模型各层的功能和主要协议
    Java – 虚函数、抽象函数、抽象类、接口
    Java CAS原理
    CAP原理中的一致性
    分布式系统CAP理论与CA选择
    数据库事务的特性、隔离级别、传播策略
    Java线程与锁
    JVM内存模型
    Java对象创建的过程及对象的内存布局与访问定位
    为什么Java匿名内部类访问的方法参数或方法局部变量需要被final修饰
  • 原文地址:https://www.cnblogs.com/alexanderone/p/3853555.html
Copyright © 2020-2023  润新知