• POJ3255-Roadblocks(最短路)


    Description

    Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

    The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

    The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

    Input

    Line 1: Two space-separated integers: N and R 
    Lines 2..R+1: Each line contains three space-separated integers: AB, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

    Output

    Line 1: The length of the second shortest path between node 1 and node N

    Sample Input

    4 4
    1 2 100
    2 4 200
    2 3 250
    3 4 100

    Sample Output

    450

    Hint

    Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)
     
     
    与求最短路类似,用优先队列维护距起始点的最小值,将复杂度降低到nlog
    某顶点v的次短路,要么是到某个顶点u的最短路加上u->v,要么是到某个顶点的次短路加上u->v
    #include<iostream>
    #include<queue> 
    #include<algorithm>
    using namespace std;
    typedef pair<int,int> P;
    int main(){
        int n,r;
        cin>>n>>r;
        vector<int> dis(n+1);
        vector<int> tdis(n+1);
        vector<vector<P> > road(n+1);
        for(int i=0;i<r;i++){
            int a,b,c;
            cin>>a>>b>>c;
            road[a].push_back(P(c,b));
            road[b].push_back(P(c,a));
        } 
        priority_queue<P,vector<P>,greater<P> > que;
        fill(dis.begin(),dis.end(),INT_MAX);
        fill(tdis.begin(),tdis.end(),INT_MAX);
        que.push(P(0,1));
        dis[1]=0;
        while(!que.empty()){
            P p=que.top();
            que.pop();
            int v=p.second;
            if(tdis[v]<p.first)continue;
            for(int i=0;i<road[v].size();i++){
                P q=road[v][i];
                int to=q.second;
                int cost=q.first;
                int d=p.first+cost;
                if(d<dis[to]){
                    swap(d,dis[to]);
                    que.push(P(dis[to],to));
                }
                if(d<tdis[to]&&dis[to]<d){
                    tdis[to]=d;
                    que.push(P(tdis[to],to));
                }
            }
        }
        cout<<tdis[n]<<endl;
        return 0;
    }
  • 相关阅读:
    HTTP协议
    UI- 不易记知识点汇总
    UI- 五种手势识别总结
    idea整合 springboot jsp mybatis
    xml和map互转工具类
    ajax请求案例
    java加密工具类,可设置对应的加解密key
    ajax请求正常,返回json格式,后台没问题,浏览器500
    通过工具SecureCRTPortable将项目部署到服务器上
    修改idea自动生成在C盘的文件路径,以免电脑越用越卡
  • 原文地址:https://www.cnblogs.com/albert67/p/10327754.html
Copyright © 2020-2023  润新知