• POJ3046--Ant Counting(动态规划)


    Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants! 

    Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants. 

    How many groups of sizes S, S+1, ..., B (1 <= S <= B <= A) can be formed? 

    While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were: 

    3 sets with 1 ant: {1} {2} {3} 
    5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3} 
    5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3} 
    3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3} 
    1 set with 5 ants: {1,1,2,2,3} 

    Your job is to count the number of possible sets of ants given the data above. 

    Input

    * Line 1: 4 space-separated integers: T, A, S, and B 

    * Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive

    Output

    * Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.

    Sample Input

    3 5 2 3
    1
    2
    2
    1
    3

    Sample Output

    10

    Hint

    INPUT DETAILS: 

    Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made? 


    OUTPUT DETAILS: 

    5 sets of ants with two members; 5 more sets of ants with three members
     
     
     
    #include<iostream>
    #include<algorithm>
    #include<string.h>
    int dp[2][100005];
    int num[10005];
    #define MOD 1000000
    using namespace std;
    int main(){
        int t,a,s,b;
        cin>>t>>a>>s>>b;
        for(int i=1;i<=a;i++){
            int x;
            cin>>x;
            num[x]++;
        }     
        dp[0][0]=1;
        int total=0;
        for(int i=1;i<=t;i++){
            total+=num[i];
            memset(dp[i%2],0,sizeof(dp[i%2]));
            for(int j=0;j<=total;j++){
                for(int k=0;k<=num[i];k++){
                    dp[i%2][j]=(dp[i%2][j]+dp[(i-1)%2][j-k])% MOD;
                }
            }
        }
        int ans=0;
        for(int i=s;i<=b;i++){
            ans=(ans+dp[t%2][i])% MOD;
        }
        cout<<ans<<endl;
        return 0;
    }
  • 相关阅读:
    hadoop2.2 伪分布式环境
    java Map实现的cache manager
    Java语言基础(九)
    Java语言基础(八)
    Java语言基础(七)
    Java语言基础(六)
    Java语言基础(五)
    Java语言基础(四)
    Java语言基础(三)
    Java语言基础(二)
  • 原文地址:https://www.cnblogs.com/albert67/p/10322835.html
Copyright © 2020-2023  润新知