• 1042. Shuffling Machine (20)


    题目如下:

    Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.

    The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

    S1, S2, ..., S13, H1, H2, ..., H13, C1, C2, ..., C13, D1, D2, ..., D13, J1, J2

    where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer K (<= 20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

    Sample Input:
    2
    36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
    Sample Output:
    S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

    题目看起来较为复杂,其实本质就是实现一个1-54依次排列的序列的按需求重新排列。
    使用三个vector来,一个用来生成原序列、记录变更后序列,另一个用来记录变更的中间过程,第三个用来记录变更要求即可,注意索引从0开始,因此要求的变更序列的所有值应当-1再被记录。
    #include <iostream>
    #include <sstream>
    #include <vector>
    #include <stdio.h>
    
    using namespace std;
    
    string getCard(int pos){
        // pos 1 - 13 S
        // pos 14 - 26 H
        // pos 27 - 39 C
        // pos 40 - 52 D
        // pos 53 - 54 J
        string result = "";
        int value;
        stringstream ss;
        if(pos < 53){
            int stand = (pos - 1)/ 13;
            value = pos % 13;
            if(value == 0) value = 13;
            switch(stand){
            case 0:
                ss << 'S';
                break;
            case 1:
                ss << 'H';
                break;
            case 2:
                ss << 'C';
                break;
            case 3:
                ss << 'D';
                break;
            }
            ss << value;
            ss >> result;
            return result;
        }
        value = pos - 52;
        ss << 'J' << value;
        ss >> result;
        return result;
    }
    
    int main()
    {
        vector<int> origin,handle;
        vector<int> ask;
        handle.resize(54);
        for(int i = 1; i <= 54; i++)
            origin.push_back(i);
        int N;
        cin >> N;
        int num;
        for(int i = 0; i < 54; i++){
            scanf("%d",&num);
            ask.push_back(num-1);
        }
        for(int i = 0; i < N; i++){
            for(int j = 0; j < 54; j++){
                handle[ask[j]] = origin[j];
            }
            origin = handle;
        }
        cout << getCard(origin[0]);
        for(int i = 1; i < origin.size(); i++){
            cout << " " << getCard(origin[i]);
        }
        cout << endl;
        return 0;
    }
    


  • 相关阅读:
    题6:利用二进制表示浮点数
    题5:将整数二进制形式的奇偶位交换
    如何访问别的主机共享的文件
    排序算法------插入排序
    centos7进入单用户模式修改root密码
    排序算法------选择排序法
    排序算法------冒泡排序法
    题4:判断一个数是否时2的整数次方
    LockSupport类
    synchronized原理及锁膨胀
  • 原文地址:https://www.cnblogs.com/aiwz/p/6154144.html
Copyright © 2020-2023  润新知