• hdu 14004


    Digital Deletions

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 1955    Accepted Submission(s): 694

    Problem Description
    Digital deletions is a two-player game. The rule of the game is as following. 

    Begin by writing down a string of digits (numbers) that's as long or as short as you like. The digits can be 0, 1, 2, 3, 4, 5, 6, 7, 8, 9 and appear in any combinations that you like. You don't have to use them all. Here is an example:



    On a turn a player may either:
    Change any one of the digits to a value less than the number that it is. (No negative numbers are allowed.) For example, you could change a 5 into a 4, 3, 2, 1, or 0. 
    Erase a zero and all the digits to the right of it

    The player who removes the last digit wins.
    The game that begins with the string of numbers above could proceed like this: 



    Now, given a initial string, try to determine can the first player win if the two players play optimally both. 
     
    Input
    The input consists of several test cases. For each case, there is a string in one line.

    The length of string will be in the range of [1,6]. The string contains only digit characters.

    Proceed to the end of file.
    Output
    Output Yes in a line if the first player can win the game, otherwise output No.
    Sample Input
    0
    00
    1
    20

     
    Sample Output
    Yes
    Yes
    No
    No
     
    HDU 1404  Digital Deletions

    一串由0~9组成的数字,可以进行两个操作:1、把其中一个数变为比它小的数;2、把其中一个数字0及其右边的所以数字删除。

    两人轮流进行操作,最后把所以数字删除的人获胜,问前者胜还是后者胜。

    字符串长度为1-6,前者胜输出Yes,否则输出No.

    程序:

     
    /*
    HDU 1404
    */
    #include<stdio.h>
    #include<math.h>
    #include<iostream>
    #include<string.h>
    using namespace std;

    const int MAXN=1000000;
    int sg[MAXN];
    int get_length(int n)//得到整数n的位数
    {
    if(n/100000) return 6;
    if(n/10000) return 5;
    if(n/1000) return 4;
    if(n/100) return 3;
    if(n/10) return 2;
    return 1;
    }

    void _extend(int n)//sg[n]=0;表示n为后者必胜
    //那么所以可以一步变成n的都是前者必胜
    {
    int len=get_length(n);
    int i;
    for(i=len;i>=1;i--)//每一个位上加上一个数
    {
    int m=n;
    int base=1;
    for(int j=1;j<i;j++) base*=10;
    int tmp=(m%(base*10))/base;
    for(int j=tmp;j<9;j++)
    {
    m+=base;
    sg[m]=1;//m为前者必胜点
    }
    }
    if(len!=6)//长度小于6,则可以在后面加0开头的
    {
    int m=n;
    int base=1;
    for(int i=len;i<6;i++)
    {
    m*=10;
    for(int b=0;b<base;b++)
    sg[m+b]=1;
    base*=10;
    }
    }
    }
    void fun()
    {
    memset(sg,0,sizeof(sg));
    sg[0]=1;
    for(int i=1;i<MAXN;i++)
    {
    if(!sg[i]) _extend(i);
    }
    }
    int main()
    {
    char str[8];
    int n;
    fun();
    while(scanf("%s",&str)!=EOF)
    {
    if(str[0]=='0') //第一个数字是0,则前者必胜
    {
    printf("Yes ");
    continue;
    }
    int len=strlen(str);//第一个数字非0,再转化成整型数
    n=0;
    for(int i=0;i<len;i++)
    {
    n*=10;
    n+=str[i]-'0';
    }
    if(sg[n]) printf("Yes ");
    else printf("No ");
    }
    return 0;
    }
  • 相关阅读:
    添加远程库
    Git远程仓库
    Git 删除文件
    Git撤销暂存区stage中的内容
    Git 暂存区的概念
    Git add和commit步骤分析
    2017CCPC秦皇岛 E题String of CCPC&&ZOJ3985【模拟】
    2017CCPC秦皇岛 C题Crusaders Quest&&ZOJ3983【模拟+STL】
    2017CCPC秦皇岛 L题One-Dimensional Maze&&ZOJ3992【模拟】
    HDU2444 The Accomodation of Students【匈牙利算法】
  • 原文地址:https://www.cnblogs.com/ainixu1314/p/3932726.html
Copyright © 2020-2023  润新知