• hdu 1452 Happy 2004


    Happy 2004

    不知道怎么转载就复制过来了

    原地址是:http://www.cnblogs.com/372465774y/archive/2012/10/22/2733977.html
    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 673    Accepted Submission(s): 481



    Problem Description
    Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

    Take X = 1 for an example. The positive
     integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668,
    and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
     

    Input
    The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000).

    A test case of X = 0 indicates the end of input, and should not be processed.
     

    Output
    For each test case, in a separate line, please output the result of S modulo 29.
     

    Sample Input
    10000

     

    Sample Output
    10

     

    Source
     ACM暑期集训队练习赛(六)
     

    Recommend
    lcy
    求约数的和
    首先 约束和函数是积性函数(就是如果m,n互质,则 f(mn)=f(m)f(n))
      还有约数个数函数也是积性函数 这2个比较好证明 直接带入就可以
    S(x)代表x的约数和
    S(20)=S(4)*S(5)
    如果p是素数 S(p^n)=1+p+p^2+...p^n=(p^(n+1)-1)/(p-1);
    所以本题 S(2004^x)=(2^(2*x+1)-1)(3^(x+1)-1)/2*(167^(x+1)-1)/166

    而又同余性质  : 若 a=b(mod m) 则 a^k=b^k (mod m):
    所以 167可以用 22代替,(对29 同余)
    对于  a^k*b^h*...%m的题目 直接二进制快速运算
    这里还有个 a^k/d % m
    这就相当于 a^k*d-1%m
    d-1 是 d的模m逆  就是  dd-1=1 mod m  ...1
    这样的话               a^k/b=x mod m ...2
                      由1,2根据同余性质 a^k*d-1=x mod m
    所以本题就Ok了
    #include <iostream>
    #include <map>
    #include <stdio.h>
    #include <math.h>
    #include <string.h>
    #include <stdlib.h>
    #include <algorithm>
    using namespace std;
    int Mod(int a,int b)
    {
        int t;
        for(t=1;b>0;b>>=1,a=(a*a)%29)
         if(b&1) t=(t*a)%29;
        return t;
    }
    int main()
    {
        int n;
        int a,b,c;
        while(scanf("%d",&n),n)
        {
             a=(Mod(2,2*n+1)-1);
             b=(Mod(3,n+1)-1)*15; 15是2的mod 29逆
             c=(Mod(22,n+1)-1)*18;18是 21的mod 29逆
             printf("%d ",a*b*c%29);
        }

        return 0;
    }

  • 相关阅读:
    05流程图和流程定义的操作
    04启动流程实例,任务的查询与完成
    03流程图的绘制与部署
    02数据库表的初始化方式
    01环境安装
    JavaScript基础和JavaScript内置对象:
    用手机、pid作为win电脑扩展屏
    H5新增特性之语义化标签
    盒模型
    CSS定位总结--static、relative、absolute、fixed
  • 原文地址:https://www.cnblogs.com/ainixu1314/p/3220959.html
Copyright © 2020-2023  润新知