• 浙江大学PAT上机题解析之1006. Sign In and Sign Out (25)


    1006. Sign In and Sign Out (25)

    时间限制 
    400 ms
    内存限制 
    32000 kB
    代码长度限制 
    16000 B
    判题程序   
    Standard
    作者   
    CHEN, Yue

    At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door.  Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

    Input Specification:

    Each input file contains one test case. Each case contains the records for one day.  The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

    ID_number Sign_in_time Sign_out_time
    

    where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

    Output Specification:

    For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day.  The two ID numbers must be separated by one space.

    Note:  It is guaranteed that the records are consistent.  That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

    Sample Input:
    3
    CS301111 15:30:28 17:00:10
    SC3021234 08:00:00 11:25:25
    CS301133 21:45:00 21:58:40
    
    Sample Output:
    SC3021234 CS301133
    
     
    #include <iostream>
    #include <string>
    #include <vector>
    #include <algorithm>
    
    using namespace std;
    
    
    typedef struct  persons
    {
    	string ID_number;
    	string Sign_in_time;
    	string Sign_out_time;
    }persons;
    
    bool compare1(persons a,persons b)
    {
    	return a.Sign_in_time<b.Sign_in_time;
    }
    bool compare2(persons a,persons b)
    {
    	return a.Sign_out_time>b.Sign_out_time;
    }
    
    
    
    int main()
    {
    	int M;
        persons  person;
    	cin>>M;
    	vector<persons>  vec;
    	vector<persons>::iterator it;
    
    	while(M--)
    	{
    	   cin>>person.ID_number>>person.Sign_in_time>>person.Sign_out_time;
    	   vec.push_back(person);
    	}
    	sort(vec.begin(),vec.end(),compare1);
    	cout<<vec.begin()->ID_number;
    	cout<<" ";
    	sort(vec.begin(),vec.end(),compare2);
    	cout<<vec.begin()->ID_number;
    	cout<<endl;
    
    
    
      //system("pause");
    	return 0;
    }

  • 相关阅读:
    队列的顺序存储表示---数组实现
    栈的应用---用栈计算逆波兰表达式
    栈的应用--栈用作判断平衡符号,[()]对的,[(])错的
    栈ADT的数组实现
    栈ADT的链表实现
    链表的游标实现
    链表应用之基数排序
    多项式ADT的数组实现
    ListView13添加2
    计算器的简单编写,熟悉访问器,重载
  • 原文地址:https://www.cnblogs.com/ainima/p/6331279.html
Copyright © 2020-2023  润新知