• 浙江大学PAT上机题解析之1050. String Subtraction (20)


    1050. String Subtraction (20)

    时间限制 
    10 ms
    内存限制 
    32000 kB
    代码长度限制 
    16000 B
    判题程序   
    Standard

    Given two strings S1 and S2, S = S1 - S2 is defined to be the remaining string after taking all the characters in S2 from S1.  Your task is simply to calculate S1 - S2 for any given strings.  However, it might not be that simple to do it fast.

    Input Specification:

    Each input file contains one test case.  Each case consists of two lines which gives S1 and S2, respectively.  The string lengths of both strings are no more than 104.  It is guaranteed that all the characters are visible ASCII codes and white space, and a new line character signals the end of a string.

    Output Specification:

    For each test case, print S1 - S2 in one line. 

    Sample Input:
    They are students.
    aeiou
    
    Sample Output:
    Thy r stdnts.
    
    #include <iostream>
    #include <string>
    #include <vector>
    #include <algorithm>
    
    using namespace std;
    
    string str1;
    string str2;
    
    string::iterator it1,it2;
    
    bool compare(char ch)
    {
    	for (it2=str2.begin();it2!=str2.end();it2++)
    		if (ch == *it2)
    		return true;
    return false;
    }
    
    
    int main()
    {
    
     getline(cin,str1);
     getline(cin,str2);
    
     sort(str2.begin(),str2.end());
    
     str2.erase(unique(str2.begin(),str2.end()),str2.end());
    
    str1.resize(remove_if(str1.begin(),str1.end(),compare) - str1.begin());
    
     cout<<str1<<endl;
    
      //system("pause");
    	return 0;
    }

     
     
  • 相关阅读:
    lombok工作原理分析
    jsqlparser和calcite和druid功能对比
    mysql主从备份及常见问题处理
    keepalived结合nginx实现nginx高可用
    FastDFS教程IV-文件服务器集群搭建
    FastDFS教程Ⅲ-文件服务器扩容
    fastDFS教程Ⅱ-文件服务器迁移
    FastDFS教程Ⅰ-文件服务器安装与Nginx配置
    Cognos报表调度与作业管理
    Cognos 11.0快速开发指南 Ⅱ
  • 原文地址:https://www.cnblogs.com/ainima/p/6331277.html
Copyright © 2020-2023  润新知