• 九度OnlineJudge之1002:Grading


    题目描述:

        Grading hundreds of thousands of Graduate Entrance Exams is a hard work. It is even harder to design a process to make the results as fair as possible. One way is to assign each exam problem to 3 independent experts. If they do not agree to each other, a judge is invited to make the final decision. Now you are asked to write a program to help this process.
        For each problem, there is a full-mark P and a tolerance T(<P) given. The grading rules are:
        • A problem will first be assigned to 2 experts, to obtain G1 and G2. If the difference is within the tolerance, that is, if |G1 - G2| ≤ T, this problem's grade will be the average of G1 and G2.
        • If the difference exceeds T, the 3rd expert will give G3.
        • If G3 is within the tolerance with either G1 or G2, but NOT both, then this problem's grade will be the average of G3 and the closest grade.
        • If G3 is within the tolerance with both G1 and G2, then this problem's grade will be the maximum of the three grades.
        • If G3 is within the tolerance with neither G1 nor G2, a judge will give the final grade GJ.

    输入:

        Each input file may contain more than one test case.
        Each case occupies a line containing six positive integers: P, T, G1, G2, G3, and GJ, as described in the problem. It is guaranteed that all the grades are valid, that is, in the interval [0, P].

    输出:

        For each test case you should output the final grade of the problem in a line. The answer must be accurate to 1 decimal place.

    样例输入:
    20 2 15 13 10 18
    样例输出:
            14.0
    #include <iostream>
    #include <cmath>
    #include <iomanip>
    using namespace std;
    
    int max(int a,int b,int c)
    {
    return a>b?(a>c?a:c):b;      
    }
    
    
    int main()
    {
    
    int P,T,G1,G2,G3,GJ;
    while(cin>>P>>T>>G1>>G2>>G3>>GJ)
    {
       float grade=0;
       if(fabs(G1-G2)<=T) grade =  (G1+G2)/2.0;
       else
       if(fabs(G1-G3)<=T && fabs(G2-G3)>T) grade= (G3+G1)/2.0;
       else
       if(fabs(G2-G3)<=T && fabs(G1-G3)>T) grade= (G3+G2)/2.0;
       else
       if(fabs(G1-G3)<=T && fabs(G2-G3)<=T) grade = max(G1,G2,G3);
       else  grade=GJ;
           
       cout<<fixed<<setprecision(1)<<grade<<endl;    
           
           
           
    }
    
    
    
    
      //system("pause");
    	return 0;
    }
    


  • 相关阅读:
    linux下测试web访问及网络相关的命令
    linux下的数据备份工具rsync讲解
    Centos安装PHP PS:LAMP环境时,为少出错误,先安装一下编译环境
    Centos6.6安装MySQL5.6.24
    Centos6.6安装apache2.4
    bash_profile和bashrc区别
    Centos安装 Apache2.4提示 APR not found的解决办法
    ERROR 1010 (HY000): Error dropping database (can't rmdir './test/', errno: 17)
    MySQL ibdata1文件迁移
    Linux启动/停止/重启Mysql数据库的方法
  • 原文地址:https://www.cnblogs.com/ainima/p/6331262.html
Copyright © 2020-2023  润新知