• POJ2236 Wireless Network 并查集简单应用


    Description

    An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

    In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

    Input

    The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
    1. "O p" (1 <= p <= N), which means repairing computer p. 
    2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

    The input will not exceed 300000 lines. 

    Output

    For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
     
    Sample
    Sample Input
    
    4 1
    0 1
    0 2
    0 3
    0 4
    O 1
    O 2
    O 4
    S 1 4
    O 3
    S 1 4
    Sample Output
    
    FAIL
    SUCCESS

    题意:

      一张图上分布着n台坏了的电脑,并知道它们的坐标。两台修好的电脑如果距离<=d就可以联网,也可以通过其他修好的电脑间接相连。给出操作“O x”表示修好x,给出操作“S x y”,请你判断x和y在此时有没有连接上。

    思路:

      并查集的简单应用,将修好的做一下标记,修好一台,与每一台做了标记的遍历检查,遍历时要加上距离这个判断条件。

    代码:

    #include<iostream>
    #include<stack>
    #include<queue>
    #include<stdio.h>
    #include<stdlib.h>
    #include<math.h>
    using namespace std;
    int pre[20010];
    int logo[20010];
    struct  node
    {
        int x;
        int y;
    } edge[40010];
    int find(int x)
    {
        if(x!=pre[x])
            pre[x]=find(pre[x]);
        return pre[x];
    }
    void merge(int x,int y)
    {
        int fx=find(x);
        int fy=find(y);
        if(fx!=fy)
        {
            pre[fy]=fx;
        }
    }
    double dis(struct  node a,struct  node b)//求两点之间的距离
    {
        return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
    }
    int main()
    {
        int n;
        double maxdis;
        cin>>n>>maxdis;
        for(int i=1; i<=n; i++)
        {
            cin>>edge[i].x>>edge[i].y;
        }
        for(int i=1; i<=n; i++)
        {
            pre[i]=i;
            logo[i]=0;
        }
        char ch;
        while(~scanf("%c",&ch))
        {
            int x,y;
            if(ch=='O')
            {
                cin>>x;
                logo[x]=1;//修好的标记为1
                for(int i=1; i<=n; i++)
                {
                    if((dis(edge[i],edge[x])<=maxdis)&&logo[i]==1)//如果修好了,并且距离不大于规定距离,则可以并
                        merge(i,x);
                }
            }
            if(ch=='S')
            {
                cin>>x>>y;
                if(find(x)==find(y))
                    cout<<"SUCCESS"<<endl;
                else
                    cout<<"FAIL"<<endl;
            }
        }
    }
  • 相关阅读:
    http://code.google.com/p/restassured/wiki/Usage#Usage
    TestNG如何修改运行结果(通过使用监听器和报表器,可以很轻松的生成自己的TestNG报表)
    MongoDB笔记
    分布式搜索elasticsearch配置文件详解
    分布式搜索ElasticSearch几个概念解析
    android rom制作
    正确配置Linux系统ulimit值的方法
    分布式搜索ElasticSearch单机与服务器环境搭建
    Mongodb亿级数据量的性能测试
    Too many open files问题分析
  • 原文地址:https://www.cnblogs.com/aiguona/p/7223722.html
Copyright © 2020-2023  润新知