• UVA1225


    Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N (1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is:

    12345678910111213

    In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program.

    Input 

    The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets.

    For each test case, there is one single line containing the number N .

    Output 

    For each test case, write sequentially in one line the number of digit 0, 1,...9separated by a space.

    Sample Input 

    2 
    3 
    13
    

    Sample Output 

    0 1 1 1 0 0 0 0 0 0 
    1 6 2 2 1 1 1 1 1 1
    #include <iostream>
    #include <cstring>
    using namespace std;
    int main()
    {
        int a[15];
        int t,n;
        cin>>t;
        while(t--)
        {
            memset(a,0,sizeof(a));
            cin>>n;
            for(int i=1;i<=n;i++)
            {
                int t=i;
                while(t)
                {
                    int num=t%10;
                    a[num]++;
                    t/=10;
                }
            }
            for(int i=0;i<10;i++)
            {
                if(i)
                    cout<<" ";
                cout<<a[i];
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Bootstrap之Carousel问题
    IMG图片和文字同行显示
    divcss5布局
    使用PHP QR Code生成二维码
    mysql grant用户权限设置
    Linux下的压缩解压缩命令详解
    linux网站目录及Apache权限的设置
    lamp环境编译(apache2.4.7 php5.4.25 mysql 5.5.23)
    mysql开启远程访问
    lamp环境编译(实际通过)
  • 原文地址:https://www.cnblogs.com/aerer/p/9931026.html
Copyright © 2020-2023  润新知