资源限制
时间限制:1.0s 内存限制:512.0MB
问题描述
给定n个十六进制正整数,输出它们对应的八进制数。
输入格式
输入的第一行为一个正整数n (1<=n<=10)。 接下来n行,每行一个由0~9、大写字母A~F组成的字符串,表示要转换的十六进制正整数,每个十六进制数长度不超过100000。
输出格式
输出n行,每行为输入对应的八进制正整数。
【注意】 输入的十六进制数不会有前导0,比如012A。 输出的八进制数也不能有前导0。
样例输入
2 39 123ABC
样例输出
71 4435274
【提示】
先将十六进制数转换成某进制数,再由某进制数转换成八进制。
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner s = new Scanner(System.in);
int n;
n = s.nextInt();
while (n > 0) {
n--;
String str;
char ansStr[] = new char[200010];
str = s.next();
int l = str.length();
int res = 0, k = 0, pos = 0;
for (int i = l - 1; i >= 0; i--) {
int temp = Integer.valueOf(str.charAt(i));
temp = temp>=65&&temp<=90 ? temp-65 + 10 : temp-Integer.valueOf('0') ;
int ttemp = 1;
if(k == 1)
ttemp = 2;
if(k == 2)
ttemp = 4;
res = ttemp * temp+ res;
ansStr[pos++] = (char)(res % 8+Integer.valueOf('0'));
k = (k + 1) % 3;
res =