• poj3020二分图匹配


    The Global Aerial Research Centre has been allotted the task of building the fifth generation of mobile phone nets in Sweden. The most striking reason why they got the job, is their discovery of a new, highly noise resistant, antenna. It is called 4DAir, and comes in four types. Each type can only transmit and receive signals in a direction aligned with a (slightly skewed) latitudinal and longitudinal grid, because of the interacting electromagnetic field of the earth. The four types correspond to antennas operating in the directions north, west, south, and east, respectively. Below is an example picture of places of interest, depicted by twelve small rings, and nine 4DAir antennas depicted by ellipses covering them. 
     
    Obviously, it is desirable to use as few antennas as possible, but still provide coverage for each place of interest. We model the problem as follows: Let A be a rectangular matrix describing the surface of Sweden, where an entry of A either is a point of interest, which must be covered by at least one antenna, or empty space. Antennas can only be positioned at an entry in A. When an antenna is placed at row r and column c, this entry is considered covered, but also one of the neighbouring entries (c+1,r),(c,r+1),(c-1,r), or (c,r-1), is covered depending on the type chosen for this particular antenna. What is the least number of antennas for which there exists a placement in A such that all points of interest are covered? 

    Input

    On the first row of input is a single positive integer n, specifying the number of scenarios that follow. Each scenario begins with a row containing two positive integers h and w, with 1 <= h <= 40 and 0 < w <= 10. Thereafter is a matrix presented, describing the points of interest in Sweden in the form of h lines, each containing w characters from the set ['*','o']. A '*'-character symbolises a point of interest, whereas a 'o'-character represents open space. 

    Output

    For each scenario, output the minimum number of antennas necessary to cover all '*'-entries in the scenario's matrix, on a row of its own.

    Sample Input

    2
    7 9
    ooo**oooo
    **oo*ooo*
    o*oo**o**
    ooooooooo
    *******oo
    o*o*oo*oo
    *******oo
    10 1
    *
    *
    *
    o
    *
    *
    *
    *
    *
    *
    

    Sample Output

    17
    5
    题真是巨长,实在看不下去,还有好多生词!直接看样例做的。
    题意:给一个图,用两个格子覆盖全部*,可以重复(和上一题这么像?)
    题解:和上一题几乎一模一样,只是需要把多余的*加上就行了,这里我把上一题题解放一下http://www.cnblogs.com/acjiumeng/p/6741545.html
    #include<map>
    #include<set>
    #include<cmath>
    #include<queue>
    #include<stack>
    #include<vector>
    #include<cstdio>
    #include<cstdlib>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    #define pi acos(-1)
    #define ll long long
    #define mod 1000000007
    
    using namespace std;
    
    const int N=400+5,maxn=100000+5,inf=0x3f3f3f3f;
    
    int n,m,col,row;
    char ma[N][N];
    int color[N],u[N][N];
    bool used[N],ok[N][N];
    
    bool match(int x)
    {
        for(int i=1;i<=row;i++)
        {
            if(ok[x][i]&&!used[i])
            {
                used[i]=1;
                if(color[i]==0||match(color[i]))
                {
                    color[i]=x;
                    return 1;
                }
            }
        }
        return 0;
    }
    int solve()
    {
        int ans=0;
        memset(color,0,sizeof color);
        for(int i=1;i<=col;i++)
        {
            memset(used,0,sizeof used);
            ans+=match(i);
        }
        return ans;
    }
    int main()
    {
        ios::sync_with_stdio(false);
        cin.tie(0);
        int t;
        cin>>t;
        while(t--){
            cin>>n>>m;
            int res=0;
            for(int i=1;i<=n;i++)
                for(int j=1;j<=m;j++)
                {
                    cin>>ma[i][j];
                    if(ma[i][j]=='*')res++;
                }
            memset(u,0,sizeof u);
            col=row=0;
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=m;j++)
                {
                    if((i+j)%2==0&&ma[i][j]=='*')u[i][j]=++col;
                    if((i+j)%2==1&&ma[i][j]=='*')u[i][j]=++row;
                }
            }
        /*    for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=m;j++)
                    cout<<u[i][j];
                cout<<endl;
            }*/
            memset(ok,0,sizeof ok);
            for(int i=1;i<=n;i++)
            {
                for(int j=1;j<=m;j++)
                {
                    if(ma[i][j]=='*')
                    {
                        if((i+j)%2==0)
                        {
                            if(i+1<=n&&ma[i+1][j]=='*')ok[u[i][j]][u[i+1][j]]=1;
                            if(j+1<=n&&ma[i][j+1]=='*')ok[u[i][j]][u[i][j+1]]=1;
                            if(i-1>=1&&ma[i-1][j]=='*')ok[u[i][j]][u[i-1][j]]=1;
                            if(j-1>=1&&ma[i][j-1]=='*')ok[u[i][j]][u[i][j-1]]=1;
                        }
                        else
                        {
                            if(i+1<=n&&ma[i+1][j]=='*')ok[u[i+1][j]][u[i][j]]=1;
                            if(i+1<=n&&ma[i+1][j]=='*')ok[u[i][j+1]][u[i][j]]=1;
                            if(i-1>=1&&ma[i-1][j]=='*')ok[u[i-1][j]][u[i][j]]=1;
                            if(j-1>=1&&ma[i][j-1]=='*')ok[u[i][j-1]][u[i][j]]=1;
                        }
                    }
                }
            }
            cout<<res-solve()<<endl;
        }
        return 0;
    }
  • 相关阅读:
    Silverlight 2 <vsm:Setter ...和<Setter ...的区别
    [原]获取指定日期WeekOfMonth
    [转]探求真正的SOA
    [转]SOA,现在进行时
    网络尖兵(NetSniper)专题
    老公必读44条守则
    Cisco2620路由器的配置与维护
    2007年银行业从业人员资格考试试题及参考答案
    可亲的“魅力水城”聊城
    我的650装机软件(供新手参考)
  • 原文地址:https://www.cnblogs.com/acjiumeng/p/6743744.html
Copyright © 2020-2023  润新知