• HDU 1018 Big Number (斯特灵公式)


    In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number. 

    InputInput consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7 on each line. 
    OutputThe output contains the number of digits in the factorial of the integers appearing in the input. 
    Sample Input

    2
    10
    20

    Sample Output

    7
    19 

    这里N的范围较小可以直接用对数做,这里还是写一下斯特灵公式的写法
    斯特林公式判断n>=1的情况,如果存在n==0则需另外特判

    
    

      斯特灵公式是一条用来取n阶乘近似值的数学公式。 公式为: 斯特林公式可以用来估算某数的大小,结合lg可以估算某数的位数,或者可以估算某数的阶乘是另一个数的倍数。 

    代码如下:

    #include <cstdio>
    #include <algorithm>
    #include <iostream>
    #include <vector>
    #include <cstring>
    #include <cmath>
    using namespace std;
    typedef long long LL;
    const double e = 2.718281828459;
    const double Pi=acos(-1.0);
    int main()
    {
        LL t,n,ans;
        cin>>t;
        while(t--)
        {
           cin>>n;
           ans=log10((2*Pi*n))/2+n*log10(n/e)+1;
           cout<<ans<<endl;
        }
        return 0;
    }
  • 相关阅读:
    python
    js 对嵌套页面的父页面进行跳转
    HTML 添加空格
    python
    python
    python
    面向对象编程基础(进阶4)
    Python模块(进阶3)
    Python函数式编程(进阶2)
    python进阶介绍(进阶1)
  • 原文地址:https://www.cnblogs.com/a249189046/p/8409296.html
Copyright © 2020-2023  润新知