• Java实现 蓝桥杯 算法训练 寻找数组中最大值


    算法训练 寻找数组中最大值
    时间限制:1.0s 内存限制:512.0MB
    提交此题
    问题描述
      对于给定整数数组a[],寻找其中最大值,并返回下标。
    输入格式
      整数数组a[],数组元素个数小于1等于100。输出数据分作两行:第一行只有一个数,表示数组元素个数;第二行为数组的各个元素。
    输出格式
      输出最大值,及其下标
    样例输入
    3
    3 2 1

    样例输出

    3 0

    import java.util.Scanner;
    
    
    public class 寻找数组中的最大值 {
    	public static void main(String[] args) {
    		Scanner sc =new Scanner(System.in);
    		int n = sc.nextInt();
    		int [] num = new int [n];
    		int max = Integer.MIN_VALUE;
    		int count = 0;
    		for (int i = 0; i < num.length; i++) {
    			num[i]=sc.nextInt();
    			if (max<num[i]) {
    				max = num[i];
    				count=i;
    			}
    			
    		}
    		System.out.println(max);
    		System.out.println(count);
    	}
    
    }
    
    
  • 相关阅读:
    2017年暑期实习生招聘(百度)——两道编程题
    携程笔试中的一道编程题
    软工假期预习作业1
    假期作业
    FAFU 1557
    HDU 1028
    POJ 3126
    HDU5108
    POJ 1716
    HDU4790
  • 原文地址:https://www.cnblogs.com/a1439775520/p/12948758.html
Copyright © 2020-2023  润新知