• BZOJ 3940--[Usaco2015 Feb]Censoring(AC自动机)


    3940: [Usaco2015 Feb]Censoring

    Time Limit: 10 Sec  Memory Limit: 128 MB
    Submit: 723  Solved: 360
    [Submit][Status][Discuss]

    Description

    Farmer John has purchased a subscription to Good Hooveskeeping magazine for his cows, so they have plenty 
    of material to read while waiting around in the barn during milking sessions. Unfortunately, the latest 
    issue contains a rather inappropriate article on how to cook the perfect steak, which FJ would rather his 
    cows not see (clearly, the magazine is in need of better editorial oversight).
    FJ has taken all of the text from the magazine to create the string S of length at most 10^5 characters. 
    He has a list of censored words t_1 ... t_N that he wishes to delete from S. To do so Farmer John finds 
    the earliest occurrence of a censored word in S (having the earliest start index) and removes that instance 
    of the word from S. He then repeats the process again, deleting the earliest occurrence of a censored word 
    from S, repeating until there are no more occurrences of censored words in S. Note that the deletion of one 
    censored word might create a new occurrence of a censored word that didn't exist before.
    Farmer John notes that the censored words have the property that no censored word appears as a substring of 
    another censored word. In particular this means the censored word with earliest index in S is uniquely 
    defined.Please help FJ determine the final contents of S after censoring is complete.
    FJ把杂志上所有的文章摘抄了下来并把它变成了一个长度不超过10^5的字符串S。他有一个包含n个单词的列表,列表里的n个单词记为t_1...t_N。他希望从S中删除这些单词。 
    FJ每次在S中找到最早出现的列表中的单词(最早出现指该单词的开始位置最小),然后从S中删除这个单词。他重复这个操作直到S中没有列表里的单词为止。注意删除一个单词后可能会导致S中出现另一个列表中的单词 
    FJ注意到列表中的单词不会出现一个单词是另一个单词子串的情况,这意味着每个列表中的单词在S中出现的开始位置是互不相同的 
    请帮助FJ完成这些操作并输出最后的S
    
    
    

    Input

    The first line will contain S. The second line will contain N, the number of censored words. The next N lines contain the strings t_1 ... t_N. Each string will contain lower-case alphabet characters (in the range a..z), and the combined lengths of all these strings will be at most 10^5.
    第一行包含一个字符串S 
    第二行包含一个整数N 
    接下来的N行,每行包含一个字符串,第i行的字符串是t_i
    
    
    

    Output

    The string S after all deletions are complete. It is guaranteed that S will not become empty during the deletion process.
    一行,输出操作后的S
     
     

    Sample Input

    begintheescapexecutionatthebreakofdawn
    2
    escape
    execution

    Sample Output

    beginthatthebreakofdawn

    题目链接:

        http://www.lydsy.com/JudgeOnline/problem.php?id=3940 

    Solution

      比较显然的AC自动机。。。

      用一个栈维护字符串当前状态。。如果匹配成功就弹栈匹配的单词长度次数。。

    代码

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<queue>
    #include<vector>
    #include<map>
    #define pa pair<LL,LL>
    #define LL long long
    using namespace std;
    inline int read(){
        int x=0,f=1;char ch=getchar();
        while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
        while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
        return x*f;
    }
    inline void Out(int a){
        if(a>9) Out(a/10);
        putchar(a%10+'0');
    }
    const LL inf=1e9+10;
    const LL mod=1e9+7;
    const int N=1e5+50;
    char t[N];
    queue<int>q;
    int m=0;
    int p[N];
    char ans[N];
    struct Aho_Corasick_Automaton{
        int c[N][26],val[N],fail[N],L[N],cnt;
        void ins(char *s){
            int len=strlen(s);int now=0;
            for(int i=0;i<len;i++){
                int v=s[i]-'a';
                if(!c[now][v])c[now][v]=++cnt;
                now=c[now][v];
            }
            val[now]++;L[now]=len;
        }
        void build(){
            for(int i=0;i<26;i++)if(c[0][i])fail[c[0][i]]=0,q.push(c[0][i]);
            while(!q.empty()){
                int u=q.front();q.pop();
                for(int i=0;i<26;i++)
                if(c[u][i])fail[c[u][i]]=c[fail[u]][i],q.push(c[u][i]);
                else c[u][i]=c[fail[u]][i];
            }
        }
        void query(char s,int now){
            ++m;
            ans[m]=s;
            now=c[now][s-'a'];
            if(val[now]) m-=L[now];
            else p[m]=now;
            return;
        }
    }AC;
    int n,len;
    char s[N];
    int main(){
    	scanf("%s",t+1);
    	scanf("%d",&n);
    	for(int i=1;i<=n;++i){
    		scanf("%s",s);
    		AC.ins(s);
    	}
    	AC.build();
    	len=strlen(t+1);
    	for(int i=1;i<=len;++i)
    		AC.query(t[i],p[m]);
    	for(int i=1;i<=m;++i) putchar(ans[i]);
    	puts("");
    	return 0;
    }
    

      

      

    This passage is made by Iscream-2001.

  • 相关阅读:
    Array的 map() 和 reduce()
    欧几里得算法求解最大公约数
    JavaScript Function
    JavaScript Hoisting(提升)
    activemq的事务消息
    Spring整合Activemq
    10张图带你深入理解Docker容器和镜像
    Thread类的interrupt方法
    简单工厂、工厂方法、抽象工厂笔记
    设计模式之观察者模式
  • 原文地址:https://www.cnblogs.com/Yuigahama/p/9671472.html
Copyright © 2020-2023  润新知