• A1002. A+B for Polynomials


    题目描述

      This time, you are supposed to find A+B where A and B are two polynomials

    输入格式

      Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK , where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,...,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤Nk<...<N2<N≤1000

    输出格式

      For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line.

    Please be accurate to 1 decimal place.

    输入样例

    2 1 2.4 0 3.2

    2 2 1.5 1 0.5

    输出样例

    3 2 1.5 1 2.9 0 3.2

    题意

    • 给出两行,每行表示一个多项式,第一个数表示该多项式中系数非零项的项数,后面每两个数表示一项,这两个数分别表示该项的幂次和系数。试求两个多项式的和,并以与前面相同的格式输出相同结果

    样例解释

    • 是第一个2是指多项式有两个系数非零项,1 2.4 表示一次项的系数为2.4,0 3.2 表示零次项的系数(即常数项)为3.2,即有F1(x)=2.4x + 3.2
    • 同样可以写出第二行所表示的多项式 F2(x)=1.5x2 + 0.5x
    • 那么 F1(x) + F2(x)=1.5x2 + 2.9x + 3.2 
    #include <bits/stdc++.h>
    const int max_n = 1111;
    double p[max_n] = {};
    int main(int argc, char *argv[]) {
        int k, n, count = 0;
        double a;
        scanf("%d", &k);
        for(int i = 0; i < k; i++){
            scanf("%d %1f", &n, &a);
            p[n] += a;
        }
        scanf("%d", &k);
        for(int i = 0; i < k; i++){
            scanf("%d %1f", &n, &a);
            p[n] += a;
        }
        for(int i = 0; i < max_n; i++){
            if(p[i] != 0){
                count++;
            }
        }
        printf("%d", count);
        for(int i = max_n - 1; i >= 0; i--){
            if(p[i] != 0){
                printf( "%d %.1f", i, p[i]);
            }
        }
        return 0;    
    }
  • 相关阅读:
    klinux下JDK的安装和卸载
    MySQL设置定时任务执行事务
    Burp Suite Intruder的4种攻击类型
    Intel重大漏洞之Meltdown和Spectre
    你的Mac还安全吗
    渗透技巧——Windows系统的帐户隐藏
    Office--CVE-2017-11882【远程代码执行】
    Kali下安装Java环境
    自动化渗透测试工具(Cobalt Strike)3.1 最新破解版
    跟着安全牛大表哥学渗透
  • 原文地址:https://www.cnblogs.com/YC-L/p/12187244.html
Copyright © 2020-2023  润新知