• HDU1046 Gridland


    Gridland

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 5259    Accepted Submission(s): 2395


    Problem Description
    For years, computer scientists have been trying to find efficient solutions to different computing problems. For some of them efficient algorithms are already available, these are the “easy” problems like sorting, evaluating a polynomial or finding the shortest path in a graph. For the “hard” ones only exponential-time algorithms are known. The traveling-salesman problem belongs to this latter group. Given a set of N towns and roads between these towns, the problem is to compute the shortest path allowing a salesman to visit each of the towns once and only once and return to the starting point.

    The president of Gridland has hired you to design a program that calculates the length of the shortest traveling-salesman tour for the towns in the country. In Gridland, there is one town at each of the points of a rectangular grid. Roads run from every town in the directions North, Northwest, West, Southwest, South, Southeast, East, and Northeast, provided that there is a neighbouring town in that direction. The distance between neighbouring towns in directions North–South or East–West is 1 unit. The length of the roads is measured by the Euclidean distance. For example, Figure 7 shows 2 × 3-Gridland, i.e., a rectangular grid of dimensions 2 by 3. In 2 × 3-Gridland, the shortest tour has length 6. 


     

    Input
    The first line contains the number of scenarios.

    For each scenario, the grid dimensions m and n will be given as two integer numbers in a single line, separated by a single blank, satisfying 1 < m < 50 and 1 < n < 50.
     

    Output
    The output for each scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. In the next line, print the length of the shortest traveling-salesman tour rounded to two decimal digits. The output for every scenario ends with a blank line.
     

    Sample Input
    2 2 2 2 3
     

    Sample Output
    Scenario #1: 4.00 Scenario #2: 6.00
     

       思路:
                找规律不难发现:
                                      当m和n都是奇数的时候,最短路径是n*m+sqrt(2)-1;
                                      当m和n中有一个是偶数的时候,最短路径是m*n;
      
        CODE:
                
    #include<iostream>
    #include<algorithm>
    #include<cstdio>
    #include<cmath>
    using namespace std;
    
    int main()
    {
        int n;cin>>n;
        int kase=1;
        while(n--)
        {
            int m,n;
            cin>>m>>n;
            if(m>n)swap(m,n);
            if(m%2+n%2==2)
                printf("Scenario #%d:
    %.2lf
    
    ",kase++,(double)m*n+sqrt(2)-1);
            else
                 printf("Scenario #%d:
    %.2lf
    
    ",kase++,(double)m*n);
        }
    }
    

        
  • 相关阅读:
    Feign Ribbon Hystrix 关系剖析
    Activiti 分布式方案实现探讨
    Flink任务架构分析
    Activiti 数据库表梳理
    负载均衡方案优缺点探讨
    公文流转系统
    css美化界面
    动手动脑(二)
    csslayui树练习
    css点名
  • 原文地址:https://www.cnblogs.com/Wu-Shi/p/5410061.html
Copyright © 2020-2023  润新知