• 杭电 1059 Dividing


    Dividing

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 27140    Accepted Submission(s): 7780


    Problem Description
    Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
    Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
     
    Input
    Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

    The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
     
    Output
    For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

    Output a blank line after each test case.
     
    Sample Input
    1 0 1 2 0 0
    1 0 0 0 1 1
    0 0 0 0 0 0
     
    Sample Output
    Collection #1: Can't be divided.
    Collection #2: Can be divided.
     

    Marsha和Bill收集了很多的石子,他们想把它均匀的分成两堆,但不幸的是,有的石子大且美观。于是,他们就给这些石子从1到6编号,表示石子的价值,以便他们可以获得相等的价值,但是他们也意识到这很难,因为石子是不能切割的,石子的总价值也未必是偶数,例如,他们分别有一个价值为1和3的石子,2个价值为4的石子,这种情况下,就不能均分了。

    思路:此题属于多重背包的问题.

    就是把多重背包的问题,转化一下,你把总价值算出来,然后再是把总价值的一半当作背包的容量,然后用模版,看看在那样的容量下,能不能装满背包,能装满就能均分。

    附上代码:

    //多重背包
    //HDU 1059
    //题意:价值分别为1,2,3,4,5,6的物品的个数分别为 a[1],a[2],````a[6]
    //问能不能分成两堆价值相等的
    
    #include <iostream>
    #include<math.h>
    #include <iomanip>
    #include<cstdio>
    #include<string>
    #include<map>
    #include<vector>
    #include<list>
    #include<algorithm>
    #include<stdlib.h>
    #include<iterator>
    #include<sstream>
    #include<string.h>
    #include<stdio.h>
    using namespace std;
    
    int c[20001],w[105],num[105];  //花费 价值 数量
    int dp[200000];
    int v,V,V1; //大V表示 容量
    
    void ZeroOnePack(int c, int w)
    {
        for(int v = V; v >=c; v--)
        {
            dp[v] = max(dp[v],dp[v-c]+w);
        }
    }
    
    void CompletePack(int c, int w)
    {
        for(int v = c; v <= V; v++)
        {
            dp[v] = max(dp[v],dp[v-c]+w);
        }
    }
    
    void MultiplePack(int c, int w, int num)
    {
        if(c * num >= V)
        {
            CompletePack(c,w);
        }
        else
        {
            int k = 1;
            while(k < num)
            {
                ZeroOnePack(k*c, k*w);
                num -= k;
                k <<= 1;
            }
            ZeroOnePack(num*c, num*w);
        }
    }
    int main()
    {
        int icase=0;
    
        while(true)
        {
            int tol=0;
            icase++;
            for(int i=1;i<=6;i++)
            {
                cin>>c[i];
                tol=tol+i*c[i];
            }
            if(tol==0)
            {
                break;
            }
            if(tol%2==1)//是奇数
            {
                cout<<"Collection #"<<icase<<":"<<endl;
                cout<<"Can't be divided."<<endl;
                cout<<endl;
                continue;
            }
            else
            {
                memset(dp,0,sizeof(dp));
                V=tol/2;//设定背包的容量为总量的一般
                for(int i=1;i<=6;i++)//i  表示的是从1 到
                {
                    MultiplePack(i,i,c[i]);
                }
                if(dp[V]==V)
                {
                    cout<<"Collection #"<<icase<<":"<<endl;
                     cout<<"Can be divided."<<endl<<endl;
                }
                else
                {
                cout<<"Collection #"<<icase<<":"<<endl;
                cout<<"Can't be divided."<<endl;
                cout<<endl;
                }
    
            }
        }
        return 0;
    }
  • 相关阅读:
    创建用户自定义函数 SQL
    关于“该列没有包含在聚合函数或 GROUP BY 子句中”
    转Oracle性能参数—经典常用
    The server committed a protocol violation. Section=ResponseHeader Detail=CR must be followed by LF 错误
    js定时刷新
    用户获取mac地址的方法
    聚集索引和非聚集索引的区别
    WCF启动报错:“进程不具有此命名空间的访问权限”的解决方法
    利用js文件加载js文件的方法
    C#下载的几种方法
  • 原文地址:https://www.cnblogs.com/William-xh/p/7373723.html
Copyright © 2020-2023  润新知