• (map)What Are You Talking About hdu1075


    What Are You Talking About
    Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
    Total Submission(s): 25683    Accepted Submission(s): 8745
     
     
    Problem Description
    Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?
     
    Input
    The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab(' '), enter(' ') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
     
    Output
    In this problem, you have to output the translation of the history book.
     
    Sample Input
    START
    from fiwohello difhmars riwosfearth fnnvklike fiiwj
    END
    START
    difh, i'm fiwo riwosf.
    i fiiwj fnnvk!
    END
     
    Sample Output
    hello, i'm from mars.
    i like earth!
    Hint
    Huge input, scanf is recommended.
     
     
     
    方法一
    #include <cctype>
    #include <map>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    string a, b;
    string s;
    map<string, string> mp;
    int main() {
    cin >> a;
    while (cin >> a) {
    if (a == "END")
    break;
    cin >> b;
    mp[b] = a;
    }
    cin >> a;
    getchar();
    while (1) {
    getline(cin,s);
    if (s=="END")
    break;
    int len = s.length(); //确定输入的字符串的长度。
    a = ""; //对字符串a初始化。
    for(int i=0;i<len;i++) {
    if (islower(s[i])) {
    a += s[i];
    } else {
    if (mp.find(a) != mp.end())
    cout << mp[a];
    else
    cout << a;
    a = ""; //对字符串进行初始化。
    cout << s[i]; //还需要输出s[i],s[i]不是小写字母,要考虑这个可能性。
    }
    }
    cout << endl;
    }
    return 0;
    }
     
    方法二:
    #include <cctype>
    #include <map>
    #include <iostream>
    #include <algorithm>
    using namespace std;
    string a, b;
    string s;
    map<string, string> mp;
    int main() {
    cin >> a;
    while (cin >> a) {
    if (a == "END")
    break;
    cin >> b;
    mp[b] = a;
    }
    cin >> a;
    getchar();
    while (1) {
    getline(cin,s);
    if (s=="END")
    break;
    int len = s.length();
    a = "";
    for(int i=0;i<len;i++) {
    if (islower(s[i])) {
    a += s[i];
    } else {
    if (mp[a]=="") //也可以这样用。
    cout<<a;
    else
    cout<<mp[a];
    a = "";
    cout << s[i];
    }
    }
    cout << endl;
    }
    return 0;
    }
     
  • 相关阅读:
    javascript-事件代理
    控制DIV属性——实现盒子长、宽、背景等变化
    mac环境下VSCODE 全局搜索无效的问题
    VSCODE snippets的使用
    JS单线程与setTimeout执行原理(转载)
    ES6
    SQL聚合函数
    MySQL函数(转发)
    关于mysql中int(1)中int后面的数字(转发)
    关于xcode8.0 VVDocumenter无法使用的解决办法
  • 原文地址:https://www.cnblogs.com/Weixu-Liu/p/9174856.html
Copyright © 2020-2023  润新知