• 10361 Automatic Poetry


    Problem I

    Automatic Poetry

    Input: standard input

    Output: standard output

    Time Limit: 2 seconds

    Memory Limit: 32 MB

    “Oh God”, Lara Croft exclaims, “it’s one of these dumb riddles again!”

    In Tomb Raider XIV, Lara is, as ever, gunning her way through ancient Egyptian pyramids, prehistoric caves and medival hallways. Now she is standing in front of some important Germanic looking doorway and has to solve a linguistic riddle to pass. As usual, the riddle is not very intellectually challenging.

    This time, the riddle involves poems containing a “Schuttelreim”. An example of a Schuttelreim is the following short poem:

    Ein Kind halt seinen Schnabel nur,

    wenn es hangt an der Nabelschnur.        

    /*German contestants please forgive me. I had to modify something as they were not appearing correctly in plain text format*/

    A Schuttelreim seems to be a typical German invention. The funny thing about this strange type of poetry is that if somebody gives you the first line and the beginning of the second one, you can complete the poem yourself. Well, even a computer can do that, and your task is to write a program which completes them automatically. This will help Lara concentrate on the “action” part of Tomb Raider and not on the “intellectual” part.

    Input

    The input will begin with a line containing a single number n. After this line follow n pairs of lines containing Schuttelreims. The first line of each pair will be of the form

    s1<s2>s3<s4>s5

    where the si are possibly empty, strings of lowercase characters or blanks. The second line will be a string of lowercase characters or blanks ending with three dots “...”. Lines will we at most 100 characters long.

    Output

    For each pair of Schuttelreim lines l1 and l2 you are to output two lines c1 and c2 in the following way: c1 is the same as l1 only that the bracket marks “<” and “>” are removed. Line c2 is the same as l2 , except that instead of the three dots the string s4s3s2s5 should appear.

    Sample Input

    3

    ein kind haelt seinen <schn>abel <n>ur

    wenn es haengt an der ...

    weil wir zu spaet zur <>oma <k>amen

    verpassten wir das ...

    <d>u <b>ist

    ...

    Sample Output

    ein kind haelt seinen schnabel nur

    wenn es haengt an der nabel schnur

    weil wir zu spaet zur oma kamen

    verpassten wir das koma amen

    du bist

    bu dist

    蛮自卑的,水题啊,唉

    #include <iostream>
    #include <cstdio>
    using namespace std;
    int pos;
    int index_begin_end[4];
    int main()
    {
        int iCase;
        scanf("%d",&iCase);
        getchar();
        char l1[110],l2[110];
        while (iCase--)
        {
            gets(l1);
            gets(l2);
            pos = 0;
            int index;
            int temp = 0;
    
            for(index = 0 ; l1[index] ; index++)
            {
                if(l1[index]!='<' && l1[index]!='>')
                    cout<<l1[index];
                else
                {
                    index_begin_end[pos++] = index;
                }
            }
            cout<<endl;
            for(index = 0 ;l2[index] && l2[index]!='.' ; ++index)
                cout<<l2[index];
    
            for(index = index_begin_end[2]+1 ;
                l1[index]!='>'; index++)
                cout<<l1[index];
            for(index = index_begin_end[1]+1 ;
                l1[index]!='<'; index++)
                cout<<l1[index];
            for(index = index_begin_end[0]+1;
                l1[index]!='>'; index++)
                cout<<l1[index];
            for(index = index_begin_end[3]+1;
                l1[index];++index)
                cout<<l1[index];
            cout<<endl;
    
        }
        return 0;
    }
    
  • 相关阅读:
    arcgis中根据坐标文件生成要素类
    论C#及.net缺点及发展
    测绘类投稿指南
    .NET 4.0 Beta2中的BigInteger和Complex类(转)
    沈阳招聘.NET(C#)高级软件工程师
    测树学weibull拟合matlab程序,难者不会,会者不难
    景观生态专用软件
    使用匿名函数在后台线程中设置窗体控件属性 ()转
    matlab如何统计矩阵各元素的出现次数
    科学计算与开发环境
  • 原文地址:https://www.cnblogs.com/UnGeek/p/2551859.html
Copyright © 2020-2023  润新知