• UVa 725 简单枚举+整数转换为字符串


     Division 

    Write a program that finds and displays all pairs of 5-digit numbers that between them use the digits 0through 9 once each, such that the first number divided by the second is equal to an integer N, where$2le N le 79$. That is,


    abcde / fghij = N

    where each letter represents a different digit. The first digit of one of the numerals is allowed to be zero.

    Input 

    Each line of the input file consists of a valid integer N. An input of zero is to terminate the program.

    Output 

    Your program have to display ALL qualifying pairs of numerals, sorted by increasing numerator (and, of course, denominator).

    Your output should be in the following general form:


    xxxxx / xxxxx = N

    xxxxx / xxxxx = N

    .

    .


    In case there are no pairs of numerals satisfying the condition, you must write ``There are no solutions for N.". Separate the output for two different values of N by a blank line.

    Sample Input 

    61
    62
    0
    

    Sample Output 

    There are no solutions for 61.
    
    79546 / 01283 = 62
    94736 / 01528 = 62
    



    Miguel Revilla 
    2000-08-31
    /*算法分析:枚举fghij就可以计算出abcde,然后判断是否所有数字都不相同即可。 {提交时系统不支持itoa函数,故写了一个整数转换为字符串函数 
    */
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <string>
    #include <cstdlib>
    using namespace std;
    
    char *reverse(char *s)  
    {  
        char temp;  
        char *p = s;    //p指向s的头部  
        char *q = s;    //q指向s的尾部  
        while(*q)  
            ++q;  
        q--;  
      
        //交换移动指针,直到p和q交叉  
        while(q > p)  
        {  
            temp = *p;  
            *p++ = *q;  
            *q-- = temp;  
        }  
        return s;  
    }  
      
    /* 
     * 功能:整数转换为字符串 
     * char s[] 的作用是存储整数的每一位 
     */  
    char *my_itoa(int n)  
    {  
        int i = 0,isNegative = 0;  
        static char s[100];      //必须为static变量,或者是全局变量  
        if((isNegative = n) < 0) //如果是负数,先转为正数  
        {  
            n = -n;  
        }  
        do      //从各位开始变为字符,直到最高位,最后应该反转  
        {  
            s[i++] = n%10 + '0';  
            n = n/10;  
        }while(n > 0);  
      
        if(isNegative < 0)   //如果是负数,补上负号  
        {  
            s[i++] = '-';  
        }  
        s[i] = '';    //最后加上字符串结束符  
        return reverse(s);    
    } 
    
    int panDuan(int a, int b) {
    	char a1[10], b1[10];
    	
    	memset(a1, 0, sizeof(a1));
    	memset(b1, 0, sizeof(b1));
    	strcpy(a1, my_itoa(a));
    	strcpy(b1, my_itoa(b));
    	
    	
    	int flag = 0;
    	for (int i = 0; i<strlen(a1); i++) {
    		for (int j = 0; j<strlen(b1); j++) {
    			if (a1[i] == b1[j])	flag = 1;
    		}
    	}
    	for (int i = 0; i<strlen(a1); i++) {
    		for (int j = 0; j<strlen(a1) && i!=j; j++) {
    			if (a1[i] == a1[j])	flag = 1;
    		}
    	}
    	for (int i = 0; i<strlen(b1); i++) {
    		for (int j = 0; j<strlen(b1) && i!=j; j++) {
    			if (b1[i] == b1[j])	flag = 1;
    		}
    	}
    	if (flag)	return 0;
    	return 1;
    }
    
    int main() {
    	int n, f1 = 0;
    	while (cin >> n && n) {
    		if (f1)	cout << endl;
    		f1 = 1;
    		int flag = 0;
    		for (int i = 1000; i<=99999; i++) {
    			int num = i*n;
    			int f = i;
    			if (num>=10000 && num<100000) {
    				if (f < 10000)	f *= 10;
    				if (panDuan(f, num)) {
    					
    					flag = 1;
    					cout << num << " / " ;
    					if (i<10000)	cout << 0<< i<< " = "<< n << endl;
    					else	cout << i<< " = "<< n << endl;
    				}
    			}
    		}
    		if (!flag)	cout << "There are no solutions for " << n<< "." << endl;
    		
    	}
    	return 0;
    }


  • 相关阅读:
    LayUI上传图片
    快递查询
    安装 Python
    HTML5 WebSocket
    反射实例
    反射
    工厂模式之工厂方法案例
    工厂模式之简单工厂案例
    第三方登录
    封装条形码MaHelper
  • 原文地址:https://www.cnblogs.com/Tovi/p/6194813.html
Copyright © 2020-2023  润新知