• poj_2503(map映射)


    题目链接poj2503

    Babelfish
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 38820   Accepted: 16578

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    

    Hint

    Huge input and output,scanf and printf are recommended.

    Source

    /*题目大意:给定一系列外国单词,都对应着英语单词。然后给一个外国单词,要求输出相对应的英语单词。若不存在则输出eh 
      算法分析:可以根据map的映射关系 
    */
     
    #include <iostream>
    #include <map>
    #include <string>
    #include <cstring>
    #include <cstdlib>
    #include <cstdio>
    using namespace std;
    
    int main() {
    	map <string, bool> appear;		//记录单词是否出现 
    	map <string , string > p;		//单词映射 
    	
    	char t;
    	while (true) {
    		char english[20];
    		char t;				//临时字符 
    		t = getchar();
    		if (t == '
    ')	break;		//如果是换行符,跳出 
    		int i = 1;
    		english[0] = t;
    		while (true) {
    			t = getchar();
    			if (t == ' ') {
    				english[i] = '';		
    				break;
    			}
    			else	english[i++] = t;
    		}
    		string forign;
    		cin >> forign;
    		getchar();			//吃掉换行符 
    		appear[forign] = true;
    		p[forign] = english;
    	}
    	string word;
    	while (cin >> word) {
    		if (appear[word]) 	cout << p[word] << endl;
    		else	cout << "eh" << endl;
    	}
    	return 0;
    }


  • 相关阅读:
    【转】Android 6.0 Marsmallow BLE : Connection Parameters
    过滤掉字符串中重复的字符
    从第一个汉字开始分割字符串
    根据年月生成日历函数
    计算两个日期之间的工作日
    根据日期返回星座
    检查给定串是否存在于由区间及点集的结合内
    将整型数字转换为大写汉字
    向左填充指定字符串
    人民币小写金额转大写
  • 原文地址:https://www.cnblogs.com/Tovi/p/6194806.html
Copyright © 2020-2023  润新知