• poj_2503(map映射)


    题目链接poj2503

    Babelfish
    Time Limit: 3000MS   Memory Limit: 65536K
    Total Submissions: 38820   Accepted: 16578

    Description

    You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

    Input

    Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

    Output

    Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".

    Sample Input

    dog ogday
    cat atcay
    pig igpay
    froot ootfray
    loops oopslay
    
    atcay
    ittenkay
    oopslay
    

    Sample Output

    cat
    eh
    loops
    

    Hint

    Huge input and output,scanf and printf are recommended.

    Source

    /*题目大意:给定一系列外国单词,都对应着英语单词。然后给一个外国单词,要求输出相对应的英语单词。若不存在则输出eh 
      算法分析:可以根据map的映射关系 
    */
     
    #include <iostream>
    #include <map>
    #include <string>
    #include <cstring>
    #include <cstdlib>
    #include <cstdio>
    using namespace std;
    
    int main() {
    	map <string, bool> appear;		//记录单词是否出现 
    	map <string , string > p;		//单词映射 
    	
    	char t;
    	while (true) {
    		char english[20];
    		char t;				//临时字符 
    		t = getchar();
    		if (t == '
    ')	break;		//如果是换行符,跳出 
    		int i = 1;
    		english[0] = t;
    		while (true) {
    			t = getchar();
    			if (t == ' ') {
    				english[i] = '';		
    				break;
    			}
    			else	english[i++] = t;
    		}
    		string forign;
    		cin >> forign;
    		getchar();			//吃掉换行符 
    		appear[forign] = true;
    		p[forign] = english;
    	}
    	string word;
    	while (cin >> word) {
    		if (appear[word]) 	cout << p[word] << endl;
    		else	cout << "eh" << endl;
    	}
    	return 0;
    }


  • 相关阅读:
    spring @Async异步方法使用及原理说明
    表达式树使用(一)
    Solr.NET快速入门(九)【二进制文档上传】【完】
    Solr.NET快速入门(八)【多核多实例,映射验证】
    Solr.NET快速入门(七)【覆盖默认映射器,NHibernate集成】
    Solr.NET快速入门(五)【聚合统计,分组查询】
    Solr.NET快速入门(四)【相似查询,拼写检查】
    Solr.NET快速入门(三)【高亮显示】
    Solr.NET快速入门(二)
    Solr快速入门(一)
  • 原文地址:https://www.cnblogs.com/Tovi/p/6194806.html
Copyright © 2020-2023  润新知