• UVA424高精度加法


    One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of
    powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
    “This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”
    (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky
    apartments on Third Street.)
    Input
    The input will consist of at most 100 lines of text, each of which contains a single VeryLongInte-
    ger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no
    VeryLongInteger will be negative).
    The final input line will contain a single zero on a line by itself.
    Output
    Your program should output the sum of the VeryLongIntegers given in the input.
    Sample Input
    123456789012345678901234567890
    123456789012345678901234567890
    123456789012345678901234567890
    0
    Sample Output
    370370367037037036703703703670
    #include <bits/stdc++.h>
    using namespace std;
    
    string add(string a, string b) {
        string c;
        int p1 = a.size(), p2 = b.size();
        int p = max(p1, p2), l = 0;
        while (1) {
            int k = (int)a[p1-1]-48+(int)b[p2-1]-48+l;
            char m = (char)48+k%10;
            c += m;
            l = k/10;
            p1 --, p2 --;
            if (p1 == 0 || p2 == 0) break;
        }
        if (p1 == 0 && p2 == 0) {
            if (l!=0) {
                char m = (char)48+l;
                c += m;
            }
        }
        else if (p1 != 0 && p2 == 0) {
            for (int i = p1; i>0; i--) {
                int k = (int)a[i-1]-48+l;
                char m = (char)48+k%10;
                c += m;
                l = k/10;
            }
            if (l!=0) {
                char m = (char)48+l;
                c += m;
            }
        }
        else if (p1 == 0 && p2 != 0) {
            for (int i = p2; i>0; i--) {
                int k = (int)b[i-1]-48+l;
                char m = (char)48+k%10;
                c += m;
                l = k/10;
            }
            if (l!=0) {
                char m = (char)48+l;
                c += m;
            }
        }
        string q;
        for (int i = 0; i<c.size(); i++)    q += c[c.size()-i-1];
        return q;
    }
    
    
    int main() {
        string s, a;
        a = "", s="0";
        int flag = 0;
        //cout <<add("9345", "900") <<endl;
        //cout << s << endl;
        while (cin >> a) {
            if (a[0] == '0')    break;
            
            s = add(s, a);
           // cout << s <<endl;
        }
        cout <<s <<endl;
        return 0;
    }


  • 相关阅读:
    验证或是提示字段请求值
    正则表达式模式
    Linux下squid代理缓存服务环境部署
    memcached缓存知识简单梳理
    MySQL 读写分离方案-Amoeba环境部署记录
    linux系统终端命令提示符设置(PS1)记录
    Gitlab快速部署及日常维护(社区版RPM包方式安装)
    Linux下检测IP地址冲突及解决方法
    Linux如何挂载Windows下的共享文件
    定时备份Windows文件到Linux服务器上(Rsync)
  • 原文地址:https://www.cnblogs.com/Tovi/p/6194761.html
Copyright © 2020-2023  润新知