• PAT-1022 Digital Library (30 分) 字符串处理


    A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID's.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains a positive integer N (≤104) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

    • Line #1: the 7-digit ID number;
    • Line #2: the book title -- a string of no more than 80 characters;
    • Line #3: the author -- a string of no more than 80 characters;
    • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
    • Line #5: the publisher -- a string of no more than 80 characters;
    • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

    It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

    After the book information, there is a line containing a positive integer M (≤1000) which is the number of user's search queries. Then M lines follow, each in one of the formats shown below:

    • 1: a book title
    • 2: name of an author
    • 3: a key word
    • 4: name of a publisher
    • 5: a 4-digit number representing the year

    Output Specification:

    For each query, first print the original query in a line, then output the resulting book ID's in increasing order, each occupying a line. If no book is found, print Not Found instead.

    Sample Input:

    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords
    4: ZUCS Print
    5: 2011
    3: blablabla
    

    Sample Output:

    1: The Testing Book
    1111111
    2222222
    2: Yue Chen
    1111111
    3333333
    3: keywords
    1111111
    2222222
    3333333
    4: ZUCS Print
    1111111
    5: 2011
    1111111
    2222222
    3: blablabla
    Not Found
    

    题目分析 给出几本书和关键字,然后根据关键字查询书

    思路分析 把所有关键字存成一个字符串即可,然后在这个字符串查找,需要注意两点

    • ZUCS Print2 如果查询"ZUCS Print"不算,所以所查找的字符串找到后还必须判断前后是不是空格,都是空格才符合要求
    • key字符串的前面必须是一个空格,最后面也得加一个空格,防止合法的查成不合法
    • 每行之间用两个空格间隔,防止出现以下错误
      比如一本书3
      1111111
      The Testing Book
      Yue Chen
      test code debug sort keywords
      ZUCS Print
      2011
      如果查询"Book Yue"可能会查到,所以应该用两个空格来间隔

    AC代码

    #include <iostream>
    #include<bits/stdc++.h>
    #define each(a,b,c) for(int a=b;a<=c;a++)
    #define de(x) cout<<#x<<" "<<(x)<<endl
    using namespace std;
    
    const int maxn=1e4+5;
    map<string,string>M;
    
    /*
    3
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    3333333
    Another Testing Book
    Yue Chen
    test code sort keywords
    ZUCS Print2
    2012
    2222222
    The Testing Book
    CYLL
    keywords debug book
    ZUCS Print2
    2011
    6
    1: The Testing Book
    2: Yue Chen
    3: keywords
    4: ZUCS Print
    5: 2011
    3: blablabla
    */
    string ID[maxn];
    string key[maxn];
    string ans[maxn];
    int cur;
    int main()
    {
        int n;
        cin>>n;
        getchar();
        string temp;
        string buf=" ";
        each(i,1,n)
        {
            buf=" ";///忘记清空了
            cin>>ID[i];
            getchar();///注意吃掉回车
            getline(cin,temp);
            //重复5次
            buf+=temp;
            buf+="  ";///加两个空格以免连起来
            getline(cin,temp);
            buf+=temp;
            buf+="  ";
            getline(cin,temp);
            buf+=temp;
            buf+="  ";
            getline(cin,temp);
            buf+=temp;
            buf+="  ";
            getline(cin,temp);
            buf+=temp;
            buf+="  ";
            //de(buf);
            key[i]=buf+" ";///首尾各有一个空格
        }
        int m;
        cin>>m;
        getchar();
        string order;
    
        while(m--)
        {
            cur=0;
            getline(cin,order);
            cout<<order<<endl;
            order=order.substr(3);
            //de(order);
            each(i,1,n)
            {
                string s;
                //de(i);
                //de(key[i]);
                int p=key[i].find(order.c_str());
                //de(p);
                if(p!=string::npos)
                {
                    if(key[i][p-1]==' '&&key[i][p+(int)order.length()]==' ')
                    {
                        ans[cur++]=ID[i];
                    }
                }
            }
            //输出
            if(cur==0)
                puts("Not Found");
            else
            {
                sort(ans,ans+cur);
                each(i,0,cur-1)
                {
                    cout<<ans[i]<<endl;
                }
            }
    
        }
    
    }
    /*
    1111111
    The Testing Book
    Yue Chen
    test code debug sort keywords
    ZUCS Print
    2011
    */
    
    
  • 相关阅读:
    开启ecstore隐藏的功能
    对接ECOS框架(含ecstore、ocs、erp等产品)的方法【其他系统请求ecos的api接口】
    shopex 网店系统基于云登录系统的信任登录设置
    怎样获取机器码
    windows 无法连接远程桌面
    ecos框架中data/ 目录下img*文件数量过多的问题
    mac 下brew解决php安装问题
    20140708 总结
    20140705 总结
    bzoj 2751
  • 原文地址:https://www.cnblogs.com/Tony100K/p/11758031.html
Copyright © 2020-2023  润新知