• Agri-Net —poj1258


    Agri-Net
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 44670   Accepted: 18268

    Description

    Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
    Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
    Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
    The distance between any two farms will not exceed 100,000. 

    Input

    The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

    Output

    For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

    Sample Input

    4
    0 4 9 21
    4 0 8 17
    9 8 0 16
    21 17 16 0
    

    Sample Output

    28
    求把所有town连接起来所需最少边权值和,把边权值按从小到大排序,如果当前边权值连接的两边没有关系就把当前边权值相加,如果有关系当前值就没有价值,不用浪费资源联通这两个town。到最后肯定会把所有town连接~
    #include<iostream>
    #include<algorithm>
    
    using namespace std;
    
    #define N 1000005
    
    int k, n, a, f[N];
    
    struct node
    {
        int x, y, w;
    }P[N];
    
    int cmp(const void *u, const void *b)
    {
        node c, d;
        c = *(node *)u;
        d = *(node *)b;
    
        return c.w-d.w;
    }
    
    void init()
    {
        for(int i = 1; i < N; i++)
            f[i] = i;
    }
    int found(int a)
    {
        if(f[a] != a)
            f[a] = found(f[a]);
        return f[a];
    }
    
    int main()
    {
        while(cin >> n)
        {
            k = 0;
    
            init();
    
            for(int i = 1; i <= n; i++)
                for(int j = 1; j <= n; j++)
                {
                    cin >> a;
                    P[k].w = a;
                    P[k].x = i, P[k].y = j;
                    k++;
                }
    
            qsort(P, k, sizeof(P[0]), cmp);
    
            int ans = 0;
    
            for(int i = 0; i < k; i++)
        {
            int nx = found(P[i].x), ny = found(P[i].y);
    
            if(nx != ny)
            {
                f[nx] = ny;
                ans += P[i].w;
            }
        }
            //int ans = kuscral(1, n);
    
            cout << ans << endl;
        }
        return 0;
    }
    让未来到来 让过去过去
  • 相关阅读:
    穷人思维与富人思维
    纯真IP库读取文件
    memcached 分布式 一致性hash算法demo
    纯CSS画的基本图形(矩形、圆形、三角形、多边形、爱心、八卦等)
    IPhone在横屏字体变大解决办法-webkit-text-size-adjust
    js设计模式---阅读笔记002--接口
    js设计模式---阅读笔记001--富有表现力的js
    关于js继承
    js正则表达式中test,exec,match方法的区别说明
    js获取自定义的属性值
  • 原文地址:https://www.cnblogs.com/Tinamei/p/4675884.html
Copyright © 2020-2023  润新知