• Divideing Jewels


    Divideing Jewels

    时间限制: 1 Sec  内存限制: 128 MB
    提交: 63  解决: 17
    [提交][状态]

    题目描述

    Mary and Rose own a collection of jewells. They want to split the collection among themselves so that both receive an equal share of the jewels. This would be easy if all the jewels had the same value, because then they could just split the collection in half. But unfortunately, some of the jewels are larger, or more beautiful than others. So, Mary and Rose start by assigning a value, a natural number between one and ten, to each jewel. Now they want to divide the jewels so that each of them gets the same total value. Unfortunately, they realize that it might be impossible to divide the jewels in this way (even if the total value of all jewels is even). For example, if there are one jewel of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the jewels.

    输入

    Each line in the input file describes one collection of jewels to be divided. The lines contain ten non-negative integers n1 , . . . , n10 , where ni is the number of jewels of value i. The maximum total number of jewells will be 10000.
    The last line of the input file will be "0 0 0 0 0 0 0 0 0 0"; do not process this line.

    输出

    For each collection, output "#k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.".
    Output a blank line after each test case.

    样例输入

    1 0 1 2 0 0 0 0 2 0
    1 0 0 0 1 1 0 0 0 0
    0 0 0 0 0 0 0 0 0 0

    样例输出

    #1:Can't be divided.
    
    #2:Can be divided.

    提示

    来源

    第五届河南省大学生程序设计竞赛

    你一定要好好看题,一定先要==||

     

    #include<iostream>
    #include<cstdio>

    using namespace std;

    int sum[15], tot, flag;

    void DFS(int q)   // q用来存现在分到的价值
    {
          int i;
          if(flag)
              return ;
          if(q == tot)  //如果价值==tot就是可以平分
          {
              flag = 1;
              return ;
          }
          for(i = 10; i > 0; --i)  //从后往前加,后边价值大
          {
              if(sum[i] > 0 && q+i <= tot)  //  i 是价值,sum【i】是i 这个价值的有几个~
              {
                  sum[i]--;  //加上一个就减去一个
                  DFS(q+i); //看q+i 是否够一半
                  if(flag)
                      return ;
              }
          }
    }
    int main()
    {
          int i, t;
     
          for(t = 1; ; t++)  //循环开始
          {
                tot = 0;
                for(i = 1; i <= 10; i++)
                {
                    cin >> sum[i];
                    tot += sum[i] * i;  // sum【i】是i 这个价值的有几个!!tot总价值
                }

                if(!tot)
                    break; // 价值为零,循环结束,程序结束

                if(tot & 1)  //tot是奇数
                {
                      printf("#%d:Can't be divided. ", t);
                      continue;
                }
                tot >>= 1; // >>位运算里边的东西,可以百度一下,这句话意思就是tot /=2;
                flag = false; 
                DFS(0);

                if(flag)
                      printf("#%d:Can be divided. ", t);
                else printf("#%d:Can't be divided. ", t);
          }
        return 0;
    }

     

    sum【i】是i 这个价值的珠宝有几个!!

    ~~

    分享更好链接:

    http://www.cnblogs.com/dongsheng/archive/2013/04/22/3036160.html

    让未来到来 让过去过去
  • 相关阅读:
    ConcurrentHashMap之实现细节
    Java 开发 2.0: 用 Hadoop MapReduce 进行大数据分析
    mapreduce从wordcount开始
    centos 5.5 安装mysql 5.5 全程详细记录 RPM方式安装
    使用GDAL工具对OrbView3数据进行正射校正
    centos 5.5 mysql5.5 乱码
    netty vs mina netty和mina的区别
    VC欣赏、家人是阻力,极客化、国际化——90后创业生态
    悲惨而又丢人的创业经历:草根创业者含恨倾诉为什么失败
    悲惨而又丢人的创业经历:草根创业者含恨倾诉为什么失败
  • 原文地址:https://www.cnblogs.com/Tinamei/p/4481912.html
Copyright © 2020-2023  润新知