• 洛谷 2957 [USACO09OCT]谷仓里的回声Barn Echoes


    题目描述

    The cows enjoy mooing at the barn because their moos echo back, although sometimes not completely. Bessie, ever the excellent

    secretary, has been recording the exact wording of the moo as it goes out and returns. She is curious as to just how much overlap there is.

    Given two lines of input (letters from the set a..z, total length in the range 1..80), each of which has the wording of a moo on it, determine the greatest number of characters of overlap between one string and the other. A string is an overlap between two other strings if it is a prefix of one string and a suffix of the other string.

    By way of example, consider two moos:

    moyooyoxyzooo

    yzoooqyasdfljkamo

    The last part of the first string overlaps 'yzooo' with the first part of the second string. The last part of the second string

    overlaps 'mo' with the first part of the first string. The largest overlap is 'yzooo' whose length is 5.

    POINTS: 50

    奶牛们非常享受在牛栏中哞叫,因为她们可以听到她们哞声的回音。虽然有时候并不能完全听到完整的回音。Bessie曾经是一个出色的秘书,所以她精确地纪录了所有的哞叫声及其回声。她很好奇到底两个声音的重复部份有多长。

    输入两个字符串(长度为1到80个字母),表示两个哞叫声。你要确定最长的重复部份的长度。两个字符串的重复部份指的是同时是一个字符串的前缀和另一个字符串的后缀的字符串。

    我们通过一个例子来理解题目。考虑下面的两个哞声:

    moyooyoxyzooo

    yzoooqyasdfljkamo

    第一个串的最后的部份"yzooo"跟第二个串的第一部份重复。第二个串的最后的部份"mo"跟第一个串的第一部份重复。所以"yzooo"跟"mo"都是这2个串的重复部份。其中,"yzooo"比较长,所以最长的重复部份的长度就是5。

    输入输出格式

    输入格式:

    • Lines 1..2: Each line has the text of a moo or its echo

    输出格式:

    • Line 1: A single line with a single integer that is the length of the longest overlap between the front of one string and end of the other.

    输入输出样例

    输入样例#1:
    abcxxxxabcxabcd 
    abcdxabcxxxxabcx 
    
    输出样例#1:
    11 
    

    说明

    'abcxxxxabcx' is a prefix of the first string and a suffix of the second string.

    字符串哈希板子

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #define mod 1777777777
    using namespace std;
    typedef long long LL;
    char s1[81],s2[82];
    int len1,len2;
    LL g[82];
    LL f1[82],f2[82];
    void pre()
    {
        g[0]=1;
        for(int i=1;i<max(len1,len2);i++) g[i]=g[i-1]*26%mod;
        f1[0]=s1[0]-'a';
        for(int i=1;i<len1;i++) f1[i]=(f1[i-1]*26+s1[i]-'a')%mod;
        f2[0]=s2[0]-'a';
        for(int i=1;i<len2;i++) f2[i]=(f2[i-1]*26+s2[i]-'a')%mod;    
    }
    LL gethash(LL *f,int l,int r)
    {
        if(!l) return f[r];  
        return (f[r]-f[l-1]*g[r-l+1]%mod+mod)%mod;
    }
    int main()
    {
        scanf("%s%s",s1,s2);
        len1=strlen(s1);
        len2=strlen(s2);
        pre();
        for(int i=min(len1,len2);i;i--)
        {
            if(gethash(f1,0,i-1)==gethash(f2,len2-i,len2-1) ) { printf("%d",i); return 0; }
            if(gethash(f2,0,i-1)==gethash(f1,len1-i,len1-1) ) { printf("%d",i); return 0; }
        }
        printf("0");
    }
  • 相关阅读:
    php 0916
    心里话
    LibreOJ 6559 小奇采药
    计蒜客 T1658 热浪
    计蒜客 T2021 飞扬的小鸟
    POJ 1276 Cash Machine
    SCU 3366 Watering Hole
    POJ 3268 Silver Cow Party
    luogu P4568 [JLOI2011]飞行路线
    POJ 1179 Polygon
  • 原文地址:https://www.cnblogs.com/TheRoadToTheGold/p/7358180.html
Copyright © 2020-2023  润新知