• poj 3041 Asteroids


    Asteroids
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 22191   Accepted: 12038

    Description

    Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

    Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

    Input

    * Line 1: Two integers N and K, separated by a single space. 
    * Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

    Output

    * Line 1: The integer representing the minimum number of times Bessie must shoot.

    Sample Input

    3 4
    1 1
    1 3
    2 2
    3 2
    

    Sample Output

    2
    

    Hint

    INPUT DETAILS: 
    The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
    X.X 
    .X. 
    .X.
     

    OUTPUT DETAILS: 
    Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

    Source

     
    题意:一颗子弹可以清楚一行或一列的障碍,求最少用多少子弹可以清楚所有障碍
    二分图
    若(x,y)出有障碍,则由x向y连边
    然后求最小点覆盖=最大匹配数
    匈牙利算法可求,网络流也可
    匈牙利算法AC代码:
    #include<cstdio>
    #include<cstring>
    using namespace std;
    int n,m,ans;
    bool v[501];
    int a[501][501],match[501];
    bool go(int u)
    {
        for(int i=1;i<=n;i++)
         if(a[u][i]&&!v[i])
         {
             v[i]=true;
             if(!match[i]||go(match[i]))
             {
                 match[i]=u;
                 return 1;
            }
         }
        return 0;
    }
    int main()
    {
        scanf("%d%d",&n,&m);
        int x,y;
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            a[x][y]=true;
        }
        for(int i=1;i<=n;i++)
        {
            memset(v,0,sizeof(*v)*(n+1));
             if(go(i))  ans++;
        }
        printf("%d",ans);
    }
  • 相关阅读:
    一步一步制作jquery插件Tabs(ajax只请求一次效果,78行完成)
    javascript没那么简单
    jQuery插件制作备忘
    封装jQuery表格插件jqGrid,控件化jqGrid(二):显示
    shell脚本day01bash的基本特性
    pythonday01_语言元素
    pythonday01_环境搭建
    shell脚本作业
    [转]ADS简要教程
    极限挑战—C#+ODP 100万条数据导入Oracle数据库仅用不到1秒
  • 原文地址:https://www.cnblogs.com/TheRoadToTheGold/p/6725010.html
Copyright © 2020-2023  润新知