• poj 1201 Intervals


    Intervals
    Time Limit: 2000MS   Memory Limit: 65536K
         

    Description

    You are given n closed, integer intervals [ai, bi] and n integers c1, ..., cn. 
    Write a program that: 
    reads the number of intervals, their end points and integers c1, ..., cn from the standard input, 
    computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,...,n, 
    writes the answer to the standard output. 

    Input

    The first line of the input contains an integer n (1 <= n <= 50000) -- the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

    Output

    The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,...,n.

    Sample Input

    5
    3 7 3
    8 10 3
    6 8 1
    1 3 1
    10 11 1

    Sample Output

    6

    Source

     
    题目大意:给出n个区间[a,b],每个区间至少要选出c个数,求满足所有的区间最少要选出多少个数
    poj 1716的弱化版
    在此不再详细解读
    #include<cstdio>
    #include<queue>
    #include<cstring>
    #include<algorithm>
    #define N 50001
    using namespace std;
    int n,minn=50002,maxn;
    queue<int>q;
    struct node
    {
        int to,next,w;
    }e[N*3];
    int dis[N],front[N],tot;
    bool v[N];
    void add(int u,int v,int w)
    {
        e[++tot].to=v;e[tot].next=front[u];front[u]=tot;e[tot].w=w;
    }
    int main()
    {
        scanf("%d",&n);
        int x,y,z;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d%d",&x,&y,&z);y++;
            add(x,y,z);
            minn=min(x,minn);maxn=max(maxn,y);
        }
        for(int i=minn;i<maxn;i++) 
        {
            add(i,i+1,0);add(i+1,i,-1);
        }
        memset(dis,-1,sizeof(dis));
        q.push(minn);v[minn]=true;dis[minn]=0;
        while(!q.empty())
        {
            int now=q.front();q.pop();v[now]=false;
            for(int i=front[now];i;i=e[i].next)
            {
                int to=e[i].to;
                if(dis[to]<dis[now]+e[i].w)
                {
                    dis[to]=dis[now]+e[i].w;
                    if(!v[to])
                    {
                        v[to]=true;
                        q.push(to);
                    }
                }
            }
        }
        printf("%d",dis[maxn]);
    }
  • 相关阅读:
    go包初始化顺序
    go map
    go包管理
    C++ 线程池
    RAFT共识算法笔记
    最大子序列和
    常见网络攻击及其防御
    go常用标准库功能
    using代替typedef
    typename和class的区别
  • 原文地址:https://www.cnblogs.com/TheRoadToTheGold/p/6529778.html
Copyright © 2020-2023  润新知