• [解题报告]HDU 1157 Who's in the Middle


    Who's in the Middle

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 6458    Accepted Submission(s): 3158


    Problem Description
    FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

    Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
     
    Input
    * Line 1: A single integer N 

    * Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
     
    Output
    * Line 1: A single integer that is the median milk output.
     
    Sample Input
    5 2 4 1 3 5
     
    Sample Output
    3
    Hint
    INPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
     
    Source
     
    Recommend
    mcqsmall
     

    题目很简单,就是排序然后输出中位数,但是依旧WA了好多次才过。。

    为毛?

    尼玛题目你倒是说一句是循环输入啊魂淡!!!

    #include<stdio.h>
    int main()
    {
        int N;
        while(scanf("%d",&N)!=EOF)
        {
        int a[N];
        int i;
        for(i=0;i<N;i++)
        {
            scanf("%d",&a[i]);
        }
        int j,flag,temp;
        for(i=0;i<N-1;i++)//冒泡
        {
            flag=1;
            for(j=0;j<N-i-1;j++)
            {
                if(a[j]>a[j+1])
                {
                    temp=a[j+1];
                    a[j+1]=a[j];
                    a[j]=temp;
                    flag=0;
                }
            }
            if(flag==1) break;
        }
         printf("%d\n",a[(N-1)/2]);
        }
    }
  • 相关阅读:
    asp.net membership 修改密码
    linq直接执行sql语句
    word-wrap,word-break,white-space,text-overflow的区别和用法
    ObjectQuery查询及方法
    HTML 标签的 enctype 属性
    【C#学习笔记】类构造函数使用
    【C#学习笔记】播放wav文件
    【C#学习笔记】类型转换
    【C#学习笔记】函数重载
    【C#学习笔记】读文件
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/3050481.html
Copyright © 2020-2023  润新知