• [解题报告]591 Box of Bricks


      Box of Bricks 

    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?

    Input 

    The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume $1 Ÿ\le n \leŸ 50$ and$1 \leŸ h_i Ÿ\le 100$.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.

    Output 

    For each set, first print the number of the set, as shown in the sample output. Then print the line ``The minimum number of moves is k.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks the same height.

    Output a blank line after each set.

    Sample Input 

    6
    5 2 4 1 7 5
    0
    

    Sample Output 

    Set #1
    The minimum number of moves is 5.
    

    Miguel A. Revilla 
    1998-03-10
     
     
     
     
     

    最小移动次数的计算方法:
    1、算出平均数,即移动完毕后,每组有几个盒子
    2、算出平均数减每组的绝对值
    3,将算出的绝对值相加除2就是最小移动次数

     
     
     
    #include<stdio.h>
    int main()
    {
       int setnum=1,i;
       int n,box[55],average,count;
       while(scanf("%d",&n)!=EOF&&n)
       {
        average=0;
        count=0;
        for(i=0;i<n;i++)
        {
          scanf("%d",&box[i]);
          average+=box[i];
        }
        average/=n;
        for(i=0;i<n;i++)
          count+=abs(average-box[i]);
        count/=2;
        printf("Set #%d\nThe minimum number of moves is %d.\n\n",setnum++,count);
      }
      return 0;
    }
  • 相关阅读:
    数据预处理
    机器学习--有监督学习和无监督学习
    weka简介
    第10章 接口、继承与多态----类的继承3
    html5 canvas实现梦幻的3D刺猬球
    html5 canvas实现图片玻璃碎片特效
    css3实现的鼠标经过按钮特效
    CSS3 Transitions属性打造动画的下载按钮特效
    纯css3实现的幽灵按钮导航
    几行css3代码实现超炫加载动画
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2919884.html
Copyright © 2020-2023  润新知