• [解题报告] 100 The 3n + 1 problem


    100 - The 3n + 1 problem

    Time limit: 3.000 seconds

     The 3n + 1 problem 

    Background

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    The Problem

    Consider the following algorithm:

     
    		1. 		 input n

    2. print n

    3. if n = 1 then STOP

    4. if n is odd then tex2html_wrap_inline44

    5. else tex2html_wrap_inline46

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

    The Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    You can assume that no operation overflows a 32-bit integer.

    The Output

    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10
    100 200
    201 210
    900 1000
    

    Sample Output

    1 10 20
    100 200 125
    201 210 89
    900 1000 174





    解题思路:方法比较傻,就是把需要处理的数的最大循环数都输出来存到数组里面,然后再在数组里面比较大小得到最大值

    输出单个数最大循环数的模块代码
    int maxcycle(int i)
    {
        int k=0;
        while(i!=1)
        {
        if(i%2==0) i=i/2;
        else i=3*i+1;
        k++;
        }
        return k+1;
    }

    排序则用简单的选择排序

    如下整体代码

    #include<stdio.h>
    int maxcycle(int i)
    {
        int k=0;
        while(i!=1)
        {
        if(i%2==0) i=i/2;
        else i=3*i+1;
        k++;
        }
        return k+1;
    }
    
    int main()
    {
        int i,j,t,max,p,m,n;
        while(scanf("%d%d",&i,&j)!=EOF)
        {
            m=i;
            n=j;
            if(i>j) //保证前小后大;
            {
                p=i;
                i=j;
                j=p;
            }
            max=maxcycle(i);
            i++;
            for( ;i<=j;i++)
            {
                t=maxcycle(i);
                if(t>max)
                max=t;
                }
            printf("%d %d %d\n",m,n,max);
         }
         return 0;
    }





  • 相关阅读:
    Oracle数据库面试题【转载】
    年龄计算周岁
    丈夫的权力与妻子的职业水平
    JDK 8 and JRE 8 Supported Locales
    一笔画 奇点 偶点
    流水行船问题
    PL/SQL LOOP SAMPLE
    OpenCV——识别各省份地图轮廓
    OpenCV——轮廓面积及长度计算
    树莓派3安装opencv2程序无法运行
  • 原文地址:https://www.cnblogs.com/TheLaughingMan/p/2887319.html
Copyright © 2020-2023  润新知