• poj1001_Exponentiation_java高精度


    Exponentiation
    Time Limit: 500MS   Memory Limit: 10000K
    Total Submissions: 162918   Accepted: 39554

    Description

    Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. 
    This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

    Input

    The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

    Output

    The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer.

    Sample Input

    95.123 12
    0.4321 20
    5.1234 15
    6.7592  9
    98.999 10
    1.0100 12
    

    Sample Output

    548815620517731830194541.899025343415715973535967221869852721
    .00000005148554641076956121994511276767154838481760200726351203835429763013462401
    43992025569.928573701266488041146654993318703707511666295476720493953024
    29448126.764121021618164430206909037173276672
    90429072743629540498.107596019456651774561044010001
    1.126825030131969720661201

    Hint

    If you don't know how to determine wheather encounted the end of input:  s is a string and n is an integer 
    C++
     while(cin>>s>>n)
     {
     ...
     }
     c
     while(scanf("%s%d",s,&n)==2) //to  see if the scanf read in as many items as you want
     /*while(scanf(%s%d",s,&n)!=EOF) //this also work    */
     {
     ...
     }

    Source

    import java.math.BigDecimal;
    import java.math.BigInteger;
    import java.util.Scanner;
    
    public class Main {
        public static void main(String[] args) {
            Scanner sc1=new Scanner(System.in);
    
            
            while(sc1.hasNextBigDecimal()){
                BigDecimal r=sc1.nextBigDecimal();
                int n=sc1.nextInt();
                BigDecimal answerBigdecimal=r.pow(n);
                answerBigdecimal=answerBigdecimal.stripTrailingZeros();
                String anString=answerBigdecimal.toPlainString();
                if(anString.startsWith("0.")){
                    anString=anString.substring(1);
                }
                System.out.println(anString);
                
            }
            
        }
    }
  • 相关阅读:
    Windows Server 2019 mmc无法创建单元
    .NET 设置IE代理
    检测WebService是否存在
    C#读取图片像素
    23种设计模式之简单工厂
    WinForm笔记一:文本框只允许输入数字
    ADO.NET笔记(一)XML导入导出和数据库
    winform中文本框的一些案例
    C#中的二进制序列化和Json序列化
    文件流操作(FileStream,StreamReader,StreamWriter)
  • 原文地址:https://www.cnblogs.com/TWS-YIFEI/p/6063533.html
Copyright © 2020-2023  润新知