• King of Karaoke ZOJ


    https://vjudge.net/problem/ZOJ-4025/origin

    https://vjudge.net/contest/399385#problem/B

    It's Karaoke time! DreamGrid is performing the song Powder Snow in the game King of Karaoke. The song performed by DreamGrid can be considered as an integer sequence $D_1, D_2, dots, D_n$, and the standard version of the song can be considered as another integer sequence $S_1, S_2, dots, S_n$. The score is the number of integers $i$ satisfying $1 le i le n$ and $S_i = D_i$.

    As a good tuner, DreamGrid can choose an integer $K$ (can be positive, 0, or negative) as his tune and add $K$ to every element in $D$. Can you help him maximize his score by choosing a proper tune?

    Input

    There are multiple test cases. The first line of the input contains an integer $T$ (about 100), indicating the number of test cases. For each test case:

    The first line contains one integer $n$ ($1 le n le 10^5$), indicating the length of the sequences $D$ and $S$.

    The second line contains $n$ integers $D_1, D_2, dots, D_n$ ($-10^5 le D_i le 10^5$), indicating the song performed by DreamGrid.

    The third line contains $n$ integers $S_1, S_2, dots, S_n$ ($-10^5 le S_i le 10^5$), indicating the standard version of the song.

    It's guaranteed that at most 5 test cases have $n > 100$.

    Output

    For each test case output one line containing one integer, indicating the maximum possible score.

    Sample Input

    2
    4
    1 2 3 4
    2 3 4 6
    5
    -5 -4 -3 -2 -1
    5 4 3 2 1
    

    Sample Output

    3
    1
    

    Hint

    For the first sample test case, DreamGrid can choose $K = 1$ and changes $D$ to ${2,3,4,5}$.

    For the second sample test case, no matter which $K$ DreamGrid chooses, he can only get at most 1 match.

    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <vector>
    #include <map>
    using namespace std;
    
    int S[100005] = {0};
    int D[100005] = {0};
    int sub[400005] = {0};
    int main()
    {
        int T = 0;
        cin >> T;
        while(T--)
        {
            int n = 0;
            cin >> n;
            for(int i = 0;i<=400000;i++)
            {
                sub[i] = 0;
            }
            
            for(int i = 0;i<n;i++)
            {
                cin >> D[i];
            }
            for(int i = 0;i<n;i++)
            {
                cin >> S[i];
            }
            for(int i = 0;i<n;i++)
            {
                int SUB = D[i] - S[i];
                sub[SUB + 200000] += 1;
            }
            int maxp = 0;
            int max = sub[0];
            for(int i = 0;i <= 400000;i++)
            {
                if(sub[i] > max)
                {
                    maxp = i;
                    max = sub[i];
                }
            }
            cout << max << endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    tomcat7
    SSO
    搜索服务Solr集群搭建 使用ZooKeeper作为代理层
    JavaScript
    JavaScript中给onclick绑定事件后return false遇到的问题
    ES6.0简单了解
    php之gennerator
    RBAC权限管理及使用原生PHP实现
    使用YII框架的migrate迁移数据库
    shell脚本--文件包含
  • 原文地址:https://www.cnblogs.com/SutsuharaYuki/p/13813328.html
Copyright © 2020-2023  润新知