• HDU-Digital Roots(思维+大数字符串模拟)


    The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit. 

    For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39. 

    Input

    The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero. 

    Output

    For each integer in the input, output its digital root on a separate line of the output. 

    Sample Input

    24
    39
    0

    Sample Output

    6
    3

    思路:循环求解,但要考虑输入的数特别大时,就要考虑字符串模拟大数的输入了

    代码:

    #include<cstdio>
    #include<cstring>
    #include<algorithm>
    #include<iostream>
    
    using namespace std;
    int sum;
    string n;
    int root(int x) {
    	sum=0;
    	while(x) {
    		sum+=x%10;
    		x/=10;
    	}
    	return sum;
    }
    
    int main() {
    
    	while(cin>>n) {
    		if(n=="0") {
    			break;
    		}
    		int s=0;
    		for(int t=0; t<n.length(); t++) {
    			s+=n[t]-'0';
    		}
    
    		if(s>=10) {
    			while(root(s)>=10) {
    				s=sum;
    			}
    		} else {
    			sum=s;
    		}
    		cout<<sum<<endl;
    	}
    
    
    	return 0;
    }
  • 相关阅读:
    Centos7 安装python3 pip3
    VMW14.x虚拟机安装Mac10.13系统教程
    ADB命令大全
    appium服务器参数
    虚拟机VM14.X安装Mac10.12启动出现问题的解决方法
    Centos7安装vscode
    jmeter接口测试多数据组合登陆场景
    appium环境安装
    mysql命令大全
    jmeter录制请求
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10781842.html
Copyright © 2020-2023  润新知