有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。
Input
输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。
Output
给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。
其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。
Sample Input
4 3 1 2 2 3 4 3
Sample Output
1 2 4 3
代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<vector>
#include<cmath>
const int maxn=1e5+5;
typedef long long ll;
using namespace std;
vector<int>edge[505];
int in[505];
int n,m;
void init()
{
for(int t=1;t<=n;t++)
edge[t].clear();
memset(in,0,sizeof(in));
}
void TPsort()
{
priority_queue<int,vector<int>, greater<int> >q;
for(int t=1;t<=n;t++)
{
if(in[t]==0)
{
q.push(t);
}
}
vector<int>ans;
while(!q.empty())
{
int k=q.top();
q.pop();
ans.push_back(k);
for(int t=0;t<edge[k].size();t++)
{
int s=edge[k][t];
in[s]--;
if(in[s]==0)
{
q.push(s);
}
}
}
for(int t=0;t<ans.size();t++)
{
if(t!=ans.size()-1)
cout<<ans[t]<<" ";
else
{
cout<<ans[t]<<endl;
}
}
}
int main()
{
while(cin>>n>>m)
{
int a,b;
init();
for(int t=0;t<m;t++)
{
scanf("%d%d",&a,&b);
edge[a].push_back(b);
in[b]++;
}
TPsort();
}
return 0;
}