• Legal or Not (拓扑排序判环)


    ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

    We all know a master can have many prentices and a prentice may have a lot of masters too, it's legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian's master and, at the same time, 3xian is HH's master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

    Please note that the "master and prentice" relation is transitive. It means that if A is B's master ans B is C's master, then A is C's master.

    Input

    The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y's master and y is x's prentice. The input is terminated by N = 0. 
    TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.

    Output

    For each test case, print in one line the judgement of the messy relationship. 
    If it is legal, output "YES", otherwise "NO".

    Sample Input

    3 2
    0 1
    1 2
    2 2
    0 1
    1 0
    0 0

    Sample Output

    YES
    NO

    代码:

    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<queue>
    #include<stack>
    #include<map>
    #include<vector>
    #include<cmath>
    
    const int maxn=1e5+5;
    typedef long long ll;
    using namespace std;
    int n,m;
    vector<int>ans[105];
    int in[105];
    void init()
    {
    	for(int t=0;t<n;t++)
    	{
    		ans[t].clear();
    	}
    	memset(in,0,sizeof(in));	
    }
    void TPsort()
    {
    	priority_queue<int>q;
    	for(int t=0;t<n;t++)
    	{
    		if(in[t]==0)
    		{
    			q.push(t);
    		}
    	}
    	vector<int>vec;
    	while(!q.empty())
    	{
    		int k=q.top();
    		q.pop();
    		vec.push_back(k);
    		for(int t=0;t<ans[k].size();t++)
    		{
    			in[ans[k][t]]--;
    			if(in[ans[k][t]]==0)
    			{
    				q.push(ans[k][t]);
    			}
    		}
    	}
    	if(vec.size()==n)
    	{
    		cout<<"YES"<<endl;
    	}
    	else
    	{
    		cout<<"NO"<<endl;
    	}
    }
    int main()
    {
        while(cin>>n>>m)
        {
        	if(n==0)
        	{
        		break;
    		}
    		int a,b;
    		init();
    		for(int t=0;t<m;t++)
    		{
    			scanf("%d%d",&a,&b);
    			ans[a].push_back(b);
    			in[b]++;
    		}
    		TPsort();
    	}
    	return 0;
    }
  • 相关阅读:
    结构体初始化所遇到的问题
    字符串赋值注意事项
    C语言可变参数 "..."
    typedef 定义指针数组和数组指针及其使用。
    指针函数、指针数组、函数指针、数组指针、函数指针数组。
    前端回血day24 flex子项伤的CSS属性
    Fiddler使用
    一句话“截流”和“防抖”
    django.core.exceptions.ImproperlyConfigured: Requested setting INSTALLED_APPS, but settings are not configured. You must either define the environment variable DJANGO_SETTINGS_MODULE or call settings.
    Linux
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10781774.html
Copyright © 2020-2023  润新知