• Feel Good(两遍单调栈维护区间+前缀和)


    Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

    A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

    Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

    Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

    Input

    The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 10 6 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

    Output

    Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

    Sample Input

    6
    3 1 6 4 5 2
    

    Sample Output

    60
    3 5

    代码:

    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<map>
    #include<set>
    #include<stack>
    #include<queue>
    #include<vector>
    #include<cmath>
    
    const int maxn=1e5+5;
    typedef long long ll;
    using namespace std;
    ll a[maxn];
    ll sum[maxn];
    ll L[maxn];
    ll L2[maxn];
    int main()
    {
        int n;ll mn=0x3f3f3f3f;
        while(cin>>n)
        {
    	for(int t=1;t<=n;t++)
    	{
    	    scanf("%lld",&a[t]);	
    	    mn=min(mn,a[t]);
    	}
    	memset(sum,0,sizeof(sum));	
    	for(int t=1;t<=n;t++)
    	{
    		sum[t]=sum[t-1]+a[t];
    	}
    	stack<int> S1,S2;
    	while(!S1.empty())
    	{
    		S1.pop();
    	}
    	while(!S2.empty())
    	{
    		S2.pop();
    	}
    
    	for(ll t=1;t<=n;t++)
    	{
            while(S1.size() && a[S1.top()] >= a[t]) S1.pop();
            if(S1.empty())     L[t] = 0;
            else              L[t] = S1.top();
            S1.push(t);
    	}
    	for(ll t=n;t>=1;t--)
    	{
    		while(S2.size() && a[S2.top()] >= a[t]) S2.pop();
            if(S2.empty())     L2[t] = n+1;
            else              L2[t] = S2.top();
            S2.push(t);
    	}
    	ll maxnn=n*mn;//注意这个初始化,很细节 
    	int j=1,k=n;
    	for(int t=1;t<=n;t++)
    	{
    		if((sum[L2[t]-1]-sum[L[t]])*a[t]>maxnn)
    		{
    			maxnn=(sum[L2[t]-1]-sum[L[t]])*a[t];
    			j=L[t]+1;
    			k=L2[t]-1;
    		}
    	}
    	cout<<maxnn<<endl;
    	cout<<j<<" "<<k<<endl;
        }
    	return 0;
    }
  • 相关阅读:
    zabbix 4.0 监控磁盘IO的实施笔记
    梅登黑德定位系统
    sdrplay sdr 支持的sample rate
    记录一下几个中移动可以PING的检测地址及部份DNS设置
    升级mariadb 10后目录权限问题的笔记
    C#单独启动进程的几种方式及使用特点(使用不当导致端口无法释放)
    SqlBulkCopy批量插入数据时,不执行触发器和约束的解决方法
    C# 处理大量数据的技巧
    C# 几种集合性能比较
    WPF学习网址整理
  • 原文地址:https://www.cnblogs.com/Staceyacm/p/10781773.html
Copyright © 2020-2023  润新知