• POJ 1273 Drainage Ditches


    Drainage Ditches
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 67387   Accepted: 26035

    Description

    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

    Input

    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

    Output

    For each case, output a single integer, the maximum rate at which water may emptied from the pond.

    Sample Input

    5 4
    1 2 40
    1 4 20
    2 4 20
    2 3 30
    3 4 10
    

    Sample Output

    50

    _________________________________________________________________

    这好像是道网络流模板题

    但为何我做得一点模板样都没有


    /*POJ1273 Drainage Ditches*/
    //网络流模板题 
    #include<iostream>
    #include<cstdio>
    #include<vector>
    #include<algorithm>
    #include<cmath>
    #include<queue>
    #include<cstring>
    using namespace std;
    const int INF=1000000;
    struct Ed{
    	int f,t;
    	int cap,flow;
    	Ed(int u,int v,int c,int f):f(u),t(v),cap(c),flow(f){}
    };
    int s,n,m;//起点,结点数,终点 
    vector<Ed> e;//边 
    vector<int> G[2000];//邻接表,存储边序号 
    int a[600];//残量 
    int p[600];//保存线路用以回溯
    //
    void clear1(int n){//初始化 
    	for(int i=0;i<=n;i++) G[i].clear();
    	e.clear();
    }
    void add_edge(int from,int to,int cap){//添加边,正反向边相邻存储
    	e.push_back(Ed(from,to,cap,0));
    	e.push_back(Ed(to,from,0,0));
    	int si=e.size();
    	G[from].push_back(si-2);
    	G[to].push_back(si-1);//相邻两条边分别加入邻接表 
    	return;
    }
    int fl(){
    	int res=0,i;
    	for(;;){//BFS
    		memset(a,0,sizeof(a));
    		queue<int>q;
    		q.push(s);
    		a[s]=INF;
    		while(!q.empty()){
    			int x=q.front();//本轮出发点 
    			q.pop();
    			for(i=0;i<G[x].size();i++){
    				Ed& edge=e[G[x][i]];
    				if(!a[edge.t] && edge.cap>edge.flow){//之前未到达,且结点有剩余流量 
    					a[edge.t]=min(a[x],edge.cap-edge.flow);
    					p[edge.t]=G[x][i];
    					q.push(edge.t);
    				}		<pre name="code" class="cpp">			if(a[m])break;//找到增广路,退出
    }if(!a[m])break;//无增广路,结束 for(int u=m;u!=s;u=e[p[u]].f){e[p[u]].flow+=a[m];// e[p[u]^1].flow-=a[m];}res+=a[m];}return res;}int main(){s=1;while(scanf("%d%d",&n,&m)!=EOF){clear1(n);int i,j,u,v,c;for(i=1;i<=n;i++){scanf("%d%d%d",&u,&v,&c);add_edge(u,v,c);}printf("%d ",fl());}return 0;}
    
    





    本文为博主原创文章,转载请注明出处。
  • 相关阅读:
    webservice+linq
    Javascript之四
    HTML、CSS、JS课后习作——痛风诊断APP源代码
    HTML、CSS、JS课后习作——痛风诊断APP
    Javascript之三
    Javascript之二
    Javascript之一
    CSS(之五)
    CSS(之四)
    CSS(之三)
  • 原文地址:https://www.cnblogs.com/SilverNebula/p/5550599.html
Copyright © 2020-2023  润新知