• The Suspects(并查集)


    题目:

    Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
    In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
    Once a member in a group is a suspect, all members in the group are suspects.
    However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

    Input

    The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
    A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

    Output

    For each case, output the number of suspects in one line.

    Sample Input

    100 4

    2 1 2

    5 10 13 11 12 14

    2 0 1

    2 99 2

    200 2

    1 5

    5 1 2 3 4 5

    1 0

    0 0

    Sample Output

    4

    1

    1

    大意:

    在大学(NSSU)中,有很多学生小组。同一组的学生经常互相交流,学生可以加入几个小组。为了防止SARS可能传播,大学收集所有学生组的成员名单,并在其标准操作程序(SOP)中执行以下规则。
    一旦一个小组中的成员是嫌疑犯,该组中的所有成员都是嫌疑犯。
    然而,他们发现,当一个学生被认定为嫌疑犯时,不容易识别所有的嫌疑犯。你的工作是写一个程序,找出所有嫌疑犯

    分析:

    n个学生在m组中,且学生编号0~n-1,0号学生是嫌疑犯,一个组中出现一个嫌疑犯就组内所有人都是嫌疑犯,所以计算存在0的联通分支,若都不存在0,则嫌疑犯只有一个。

    附代码:

     #include<map>
    #include<cmath>
    #include<queue>
    #include<vector>
    #include<cstdio>
    #include<cstring>
    #include<iostream>
    #include<algorithm>
    using namespace std;
    int p[30000],r[30000];
    int find(int x)
    {
        return p[x]==x?x:p[x]=find(p[x]);
    }
    int main()
    {
        int n,m;
        while(~scanf("%d%d",&n,&m))
        {
            if(n==0&&m==0)
                break;
            for(int i=0; i<n; i++)
                p[i]=i;
            int sum=0;
            for(int i=0; i<m; i++)
            {
                int k,f1,f2;
                scanf("%d",&k);
                scanf("%d",&r[0]);
                for(int j=1; j<k; j++)
                {
                    scanf("%d",&r[j]);
                    f1=find(r[0]);
                    f2=find(r[j]);
                    if(f1!=f2)
                        p[f2]=f1;//不能是p[f1]=f2,至今仍未理解。
                }
            }
            for(int i=0; i<n; i++)
                if(find(i)==p[0])//注意是找与零相同的根,而不是零;
                    sum++;
            printf("%d ",sum);
        }
        return 0;
    }

    代码比较乱,没有整理出模板,本题也可以添加一数组进行标记,通过标记数组计算。

  • 相关阅读:
    DevOps的基本原则与介绍
    微信和WeChat的合并月活跃账户达6.97亿
    dedecms手机站图片错误的解决方法
    可以搜索到DedeCms后台文章列表文档id吗?或者快速定位id编辑文章
    Slyce,这家硅谷创业公司的来头你知道吗
    一个canonical标签解决site不在首页的问题
    通过html<map>标签给图片加链接
    解决后台无法进入提示DedeCMS Error: (PHP 5.3 and above) Please set 'request_order' ini value
    六小龄童终究还是没能上春晚
    excel同时冻结首行和首列怎么操作
  • 原文地址:https://www.cnblogs.com/She-Chuan/p/9492566.html
Copyright © 2020-2023  润新知